Mozilla crashes at the page

VERIFIED DUPLICATE of bug 50994

Status

()

P3
critical
VERIFIED DUPLICATE of bug 50994
18 years ago
18 years ago

People

(Reporter: jens-uwe, Assigned: rickg)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14 i686; en-US; m18) Gecko/20000903
BuildID:    2000090321

mozilla crashes on this page

Reproducible: Always
Steps to Reproduce:
1.go to http://www.amd.com/news/corppr/20152.html and see Mozilla crahsing


Actual Results:  Mozilla crashes

Expected Results:  it should not crash and render the page correct.


might be related to "my" bug 49169 ??

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

18 years ago
see this, 090104, winME

Comment 2

18 years ago
This page has two HEAD blocks - the second one is inside the Body.
The one that is in the correct location isn't part of the problem.
The DOCTYPE tag at the top is also part of the problem.
I've reduced the page down to the following html that crashes Mozilla.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Final//EN">
<HTML>
<BODY>
<HEAD>
</HEAD>
</BODY>
</HTML>

If you remove the DOCTYPE or the HEAD & /HEAD from the Body the Mozilla doesn't
crash.

Comment 3

18 years ago
Created attachment 13997 [details]
Reduced html that crashes mozilla.

Comment 4

18 years ago
Created attachment 13998 [details]
This attachment is the correct html that crashes mozilla.

Comment 5

18 years ago
--> parser
Assignee: asa → rickg
Component: Browser-General → Parser
QA Contact: doronr → janc

Comment 6

18 years ago
Duplicate, according to stack trace

*** This bug has been marked as a duplicate of 50994 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.