Not enough arguments [nsISocketTransport.close] error at http://3liz.org/geolocation/ after page loads

RESOLVED DUPLICATE of bug 513567

Status

()

Core
Geolocation
RESOLVED DUPLICATE of bug 513567
8 years ago
8 years ago

People

(Reporter: u88484, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Not enough arguments [nsISocketTransport.close] error at http://3liz.org/geolocation/ after page loads

STR:
1) Go to http://3liz.org/geolocation/
2) Click the 'Share Location' button on the geolocation notification bar
3) Once page laods, the following error appears in the error console

Error: Not enough arguments [nsISocketTransport.close] = NS_ERROR_XPC_NOT_ENOUGH_ARGS
Source file: file:///C:/Junk/firefox/components/GPSDGeolocationProvider.js
Line: 180

Comment 1

8 years ago
need to pass an error code, i think.
(Reporter)

Comment 2

8 years ago
I can't seem to reproduce this today but I did get the following once (not that it is related to this bug):

Error: this.element.scrolls is null
Source file: http://3liz.org/geolocation/OpenLayers.js
Line: 466

Comment 3

8 years ago
(In reply to comment #1)
> need to pass an error code, i think.

Yea, I missed that. Might explain why it wasn't working as expected.(transport.close() should close the sockets too)

NS_OK alright to pass back here? Saying as the close is expected?

Comment 4

8 years ago
yes, passing NS_OK should be fine in this case.  we do something very similar in the http socket code.

Comment 5

8 years ago
Duplicate of bug 513567. Fix has been landed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 513567
You need to log in before you can comment on or make changes to this bug.