Closed Bug 513367 Opened 11 years ago Closed 6 years ago

Layout of bill pay at ingdirect.com broken

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: u88484, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image Screenshot
The layout of the bill pay section at ingdirect.com is broken.  Same with or without HTML5 enabled.  This broken between the 08/13 and 08/28 builds due to last time I paid a bill on 08/13 the page was fine.  See screenshot comparing 3.5.2 and latest trunk.
Actually between 08/13 and 08/27 builds.  Will try to find exact regression this weekend.
Well I guess they just started their bogus UA sniffing because altering the UA to say Firefox/3.5.2 fixed the issue.

-> Tech Evangelism
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
I sent an email to ingdirect but if anyone has any contacts there, that would be great to get them to see this bug report.
I don't have "contacts" there, but I do have an account (as I'm assuming you do, Kurt). I'll try to look into this soon-ish.
Blocks: geckoisgecko
OS: Windows Vista → All
Hardware: x86 → All
Maybe this, only place I could see t hem sniffing for Firefox.
/jscript/eo/billpay/bill_pay.js


* Handle the onload iframe event for safari
**/
function safari_onload() {
    if(/Safari/i.test(navigator.userAgent)){        
        var _billPayTimer=setInterval(function(){
        if(/loaded|complete/.test(document.readyState)){
            clearInterval(_billPayTimer);
            billpay_onload();
        }}, 10)
    }
    else if(/Firefox/i.test(navigator.userAgent)){    
    	// this is a Firefox fix
    	// If the womAdd on the page calls safari_onload and the iframe onload
    	// is defined, then Firefox hangs
    	// so this code sets the onload on the iframe after the page onload occurs
    	// can a race condition occur where the iframe onload occurs after the page has been loaded?
    	// Appears to happen after the page load event
        document.getElementById ("billpayframe").contentWindow.onload = billpay_onload();
    }
}
Got an autmoated reply today,
"Thank you for your feedback regarding our website.  Our technology team continually works to optimize our website's performance and functionality, so I have forwarded your comments to them for consideration."
Well the page won't be broken for Firefox 3.6 users but it is still messed up for trunk users.  I never did receive a response from them.
Duplicate of this bug: 553415
Resolving WFM.  I'm pretty sure this was still broken a while ago but now that 'Minefield' is no longer in the UA string this is fixed.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Firefox is not the only Gecko browser; until someone can confirm this is fixed without having the string "Firefox" in the UA, I'm re-opening it.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Both Opera (blink) and Firefox display an invalid certificate message when trying to access
https://secure.ingdirect.com/myaccount/INGDirect/bill_pay.vm

It is happening for https://secure.ingdirect.com/
When accessing http://ingdirect.com/ users are redirected to 
https://home.capitalone360.com/redirect
a homepage giving the choice in between 
* http://www.ing.us/
* https://home.capitalone360.com/
And the message saying 'ingdirect is no longer active'.



Closing as INVALID.
Assignee: english-us → nobody
Status: REOPENED → RESOLVED
Closed: 10 years ago6 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.