Closed Bug 513415 Opened 11 years ago Closed 11 years ago

bookmarks toolbar arbitrarily replaced with a ">>" menu when placed alongside "location"

Categories

(Firefox :: Toolbars and Customization, defect)

3.5 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 447571

People

(Reporter: dan.tsafrir, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

The 'customize' context menu of the top part of the Firefox window allows users to position the 'bookmarks toolbar' alongside the 'location' (see attached ff1.pdf), so as to make the top part of the window as minimal as possible (vertically).

But this configuration lasts only immediately after the window is customized, namely, after Firefox is restarted (or ctrl-n is clicked) the entire bookmarks toolbar will be replaced with a ">>" menu within the new window (see attached ff2.pdf).
 

Reproducible: Always

Steps to Reproduce:
1. right click part of FF window and choose 'customize',
2. drag 'bookmarks toolbar' to the row of the 'location', 
3. observe it looks good and the result is as expected,
4. restart (or click ctrl-n) to open a new FF window, and
5. observe 'bookmarks toolbar' is replaced by a ">>" menu in its entirety.
Actual Results:  
all 'bookmarks toolbar' items are gone, arbitrarily replaced by a ">>" menu.

Expected Results:  
when opening new FF windows, UI configuration should remain the same as it was immediately after customization.  

Customizing should probably allow the user to set the width of the 'location' and the 'bookmarks toolbar'.
Attachment #397422 - Attachment description: good (immediately after customization) → ff1.pdf - good (immediately after customization)
Version: unspecified → 3.5 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
You need to log in before you can comment on or make changes to this bug.