Last Comment Bug 513419 - Reduce the number of instances of the "Close Firefox" dialog
: Reduce the number of instances of the "Close Firefox" dialog
Status: RESOLVED DUPLICATE of bug 401301
:
Product: Toolkit
Classification: Components
Component: Startup and Profile System (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: zombieproc
Blocks: 580046
  Show dependency treegraph
 
Reported: 2009-08-28 21:50 PDT by Alex Faaborg [:faaborg] (Firefox UX)
Modified: 2012-03-09 03:07 PST (History)
20 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Close Firefox dialog box (35.23 KB, image/png)
2009-08-28 21:50 PDT, Alex Faaborg [:faaborg] (Firefox UX)
no flags Details

Description Alex Faaborg [:faaborg] (Firefox UX) 2009-08-28 21:50:34 PDT
Created attachment 397427 [details]
Close Firefox dialog box

One window that can appear on start up is the "Close Firefox" dialog.  Things we can do to avoid this dialog (that are more advanced then giving the user a problem and a list of instructions) are:

1) wait a second or so and see if Firefox has closed, often Firefox was in the process of shutting down and the user decided to reopen it.

2) actually kill the process ourselves, it's unreasonable to expect the user to know how to kill an hung process.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-08-28 21:54:47 PDT
See also bug 295693.
Comment 2 Ria Klaassen (not reading all bugmail) 2009-08-29 01:37:07 PDT
I think it is important that any automatic actions (even waiting) are visible so that the user knows what the problem is and take measures to avoid this in the future if possible.
Comment 3 Benjamin Smedberg [:bsmedberg] 2009-08-30 11:19:01 PDT
FWIW, the "kill the process ourselves" solution is covered by bug 286355 (on Windows) and is probably technically infeasible.
Comment 4 Marco Castelluccio [:marco] 2012-02-28 11:03:46 PST

*** This bug has been marked as a duplicate of bug 401301 ***

Note You need to log in before you can comment on or make changes to this bug.