Browser crashes if strict DTD specified and unbalanced <center> tags used.

VERIFIED DUPLICATE of bug 50994

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 50994
18 years ago
13 years ago

People

(Reporter: John Hayward-Warburton, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This is a boiled-down case of an earlier bug (http://www.lowfield.co.uk/archers/).

This very short piece of code makes Mozilla on Linux segfault, nightly build
2000090506 (Tuesday morning) -- strict DTD but unbalanced <center> tag:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN"
"http://www.w3.org/TR/REC-html40/strict.dtd">
<html>
<head>
<title>Non-compliant page</title>
</head>

<body>

<center>
</body>
</html>

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 50994 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified dupe of bug 50994: "Crashing in nsCParserNode::GetNodeType, with strict
DOCTYPE and unclosed tags"
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.