Crash when navigating (deprecated?) relative URL's

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
critical
RESOLVED WORKSFORME
18 years ago
3 years ago

People

(Reporter: jesup, Assigned: blizzard)

Tracking

({crash})

Trunk
x86
FreeBSD
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
FreeBSD 4.1 20000905xx (noon EDT)
Crashes fairly consistently when navigating around the bug-test page for bug 50629.

Got to the URL.  Click on "A http:/RFC link".  Hit Back after you get to the
netscape search page.  Click on "A /RFC/ link".  Boom (usually).

The crash _appears_ to be occuring in nsWindow::UpdateIdle, perhaps in a
pure_virtual call.

2 stack backtraces to be appended.
(Reporter)

Comment 1

18 years ago
Created attachment 14035 [details]
2 stack backtraces
(Reporter)

Updated

18 years ago
Keywords: crash

Comment 2

18 years ago
Can't reproduce this crash on a build pulled ~2am last night (rh6.1 using gtk).

The stack traces, though, indicate that you are building with the xlib version
os nsWindow.cpp. pavlov says that quy@igelaus.com.au is one of the people 
working on this. -> quy@igelaus.com.au
Assignee: trudelle → quy

Comment 3

18 years ago
erk, these arn't xlib stack traces.  reassigning to blizzard, I'll take a look
at this
Assignee: quy → blizzard

Comment 4

18 years ago
Sorry, I was focussing on the line number in nsWindow.cpp, which must be 
the xlib version (unless there is some confusion in the debugger dealing 
with the symbols). [I should have made my question clearer ...]
(Reporter)

Comment 5

18 years ago
Sorry, the line numbers (at least) are horked.  Ever since I upgraded to FreeBSD
4.1 last week, GDB gives me bogus line numbers (and no arguments) for shared
libs.  Weird.  I _think_ the function names are good.  (Yes, I did a full
clobber build after upgrading).  This BSD thing happens to others too.
(Reporter)

Comment 6

18 years ago
Nominating for nsbeta3.  Crashes repeatably for me.  We need confirmation it's
a problem with other platforms (or possibly a pull-while-tree-is-open issue).

More info on repeatability - I clicked on these links, waited until something
appears, click Back, try another one of them.  After 2-7 visits of links on that
page, it crashes.
Keywords: nsbeta3, qawanted

Comment 7

17 years ago
URL now "Not Found"
I just bumped into a very similar stack trace while looking at bug 65800 and bug
61386.  I'm going to see if I can trace it any further, but this seems to still
be an issue.  This is from a nightly build from 1/19/2001, with the patches from
the two previously mentioned bugs.
Created attachment 23124 [details]
Similar stack trace
Blocks: 66164
The procedure I followed to get this bug is the one in bug 66164.  This is
completely different from the way that this bug was triggered initially (via
relative URLs).  I don't know if relative URLs still crash.
After updating to a CVS version from 1/22/2001 and applying the patches from bug
61386 and bug 61756, I no longer get this crash following the procedure
documented in bug 66164.

People still seeing this bug might want to try these patches, and see if that
makes it go away.

No longer blocks: 66164
The patches that fixed this for me have all landed.  Somebody with more
knowledge of this bug than me (I have never been able to reproduce it) might
want to see if they can reproduce it, and go ahead and close it out...

Comment 13

16 years ago
404, no testcase, 'http:/' links are covered by another bug report.
I haven't experienced anything similar to this bug in nearly a year, and no
additional stack traces have been attached, and nothing's been marked as a
duplicate of this in over a year.  Further, none of the examples (like visiting
an http:/ link) seem to trigger it anymore.

I think that somebody with the ability can probably safely close this bug out as
WORKSFORME.
(Assignee)

Comment 15

16 years ago
Works for me, too.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.