If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CSS2: 'counter()' doesn't work and content: with counter doesn't work

VERIFIED DUPLICATE of bug 3247

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 3247
17 years ago
17 years ago

People

(Reporter: Tobias Burnus, Assigned: Pierre Saslawsky)

Tracking

({verifyme})

Trunk
x86
Linux
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using 2000-09-05-08/Linux.
Use the attached file (to come) or goto the URL.

Result:
This test shows that a "content:" which contains a counter() doesn't show up at
all. I consider this as rather annyoing since content doesn't show up.
(It shows up when "content:" doesn't include a counter();

Expected:
The counter should work and the content should show up.
I don't know whether it is better to keep it the present way (nothing shows up)
or to change it to: the content shows, but not the counter (until the counter
works).
(Reporter)

Comment 1

17 years ago
Created attachment 14038 [details]
Testcase for content and counter()
This is INVALID.

We don't support counters. Thus, to allow for graceful degradation, we follow
the spec and drop any declarations that include references to counters.

This is so that you can do:

   H2:before { 
          content: 'New Chapter: ';                 /* Moz 1.0 will use this */
          content: 'Chapter ' counter(chapters);    /* Moz 2.0 will use this */
   }
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: verifyme
Resolution: --- → INVALID
(Reporter)

Comment 3

17 years ago
I don't think this is invalid, but it is rather 'future' or 'Later' since this
feature is not invalid by itself, but only not planed for Mozilla 1.0.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 4

17 years ago
Changing to later in the hope that someone will look at bugs tagged as 'Later'
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → LATER
What feature? The ignoring or the counters?
Status: RESOLVED → REOPENED
Resolution: LATER → ---
Assuming you mean the counters, this is a duplicate of bug 3247, filed in 
February of 1999.

*** This bug has been marked as a duplicate of 3247 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
Verified dup of #3247

Comment 8

17 years ago
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.