when an empty clipboard is read from an uncaught exception occurs.

VERIFIED FIXED in M18

Status

()

Core
XUL
P3
minor
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: adrian, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
Overview Description:
In linux the clipboard is not checked for an empty(null?) pointer, when one is
used to paste an error occurs.

Steps to Reproduce:
1) reboot linux.
2) Don't highlight anything with the mouse.
3) start mozilla, and wait for a window to show up.
4) press the middle button.

Actual Results:
The following appers on the term:
->>>>>>>>>>>>>> Read Clipboard from memory
JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsITransferable.getTransferData]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: readFromClipboard :: line 1202"
data: no]


Expected Results:
Nothing should happen.

Reproducibility:
100%

Build Date & Platform Bug Found:
Mozilla/5.0 (X11; U; Linux 2.2.12-20 i586; en-US; m18) Gecko/20000905

Additional Builds and Platforms Tested On:
none
is this an editor/selection issue?
Assignee: don → beppe
Component: XP Apps → Editor
QA Contact: sairuh → sujay

Comment 2

18 years ago
no, this belongs to trudelle
Assignee: beppe → trudelle
Component: Editor → XP Toolkit/Widgets
QA Contact: sujay → jrgm

Comment 3

18 years ago
Really Pavlov -- cc'ing.

Comment 4

18 years ago
->pavlov.  How bad is this in the release builds, equivalent to a crash?
Assignee: trudelle → pavlov

Comment 5

18 years ago
nsbeta3+, since this should be easier to fix than to determine whether it kills
paste for the session.  should future otherwise.
Keywords: nsbeta3
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18

Updated

18 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 6

18 years ago
checked in fix
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.