If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

I always experience a crash anytime I try to open a browser [@nsDocShell::SetupNewViewer(nsIContentViewer*) ]

RESOLVED DUPLICATE of bug 434403

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 434403
8 years ago
7 years ago

People

(Reporter: prettynova, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30618; OfficeLiveConnector.1.3; OfficeLivePatch.0.0)
Build Identifier: http://www.mozilla.com/en-US/products/download.html?product=firefox-3.5.2&os=win&lang=en-GB

After I downloded the latest firefox update, firefox crashed and since then, I have not been able to open a browser. Each time I try, I recive a "Mozilla Crash Reporter" that relays the following information:


Add-ons: {CF40ACC5-E1BB-4aff-AC72-04C2F616BCA7}:1.5.2.35,{CAFEEFAC-0016-0000-0011-ABCDEFFEDCBA}:6.0.11,{CAFEEFAC-0016-0000-0015-ABCDEFFEDCBA}:6.0.15,{B7082FAA-CB62-4872-9106-E42DD88EDE45}:2.8,{20a82645-c095-46ed-80e3-08825760534b}:1.1,{972ce4c6-7e08-4474-a285-3208198ce6fd}:3.5.2
BuildID: 20090729225027
CrashTime: 1251935521
Email: prettynova@hotmail.com
InstallTime: 1250481127
ProductName: Firefox
SecondsSinceLastCrash: 289
StartupTime: 1251935520
Theme: classic/1.0
Throttleable: 1
URL: 
Vendor: Mozilla
Version: 3.5.2

This report also contains technical information about the state of the application when it crashed.

Reproducible: Always

Steps to Reproduce:
1.Click on any firefox icon that is meant to open a browser (either desktop shortcut, shortcut on the system tray or through the start menue)
2.
3.
Actual Results:  
I receive a mozilla crash report 

Expected Results:  
opened a firefox browser

This bug started as soon as I updated firefox, after I recived a notification from them that a new update was available.

Comment 1

8 years ago
The "details" button isn't really useful. Please post the corresponding crash ID:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report#How_to_get_the_crash_ID_if_Firefox_crashes_on_startup

To troubleshoot, first please try Firefox safe mode:
http://support.mozilla.com/en-US/kb/Safe+Mode
then try a new profile:
http://support.mozilla.com/en-US/kb/Managing+Profiles
further info:
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

8 years ago
I don't really know what that means - I'm techno-competant, but not techno-savy... can you explain why you mean by the "details" button?

(In reply to comment #1)
> The "details" button isn't really useful. Please post the corresponding crash
> ID:
> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report#How_to_get_the_crash_ID_if_Firefox_crashes_on_startup
> To troubleshoot, first please try Firefox safe mode:
> http://support.mozilla.com/en-US/kb/Safe+Mode
> then try a new profile:
> http://support.mozilla.com/en-US/kb/Managing+Profiles
> further info:
> http://support.mozilla.com/en-US/kb/Basic+Troubleshooting

(In reply to comment #1)
> The "details" button isn't really useful. Please post the corresponding crash
> ID:
> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report#How_to_get_the_crash_ID_if_Firefox_crashes_on_startup
> To troubleshoot, first please try Firefox safe mode:
> http://support.mozilla.com/en-US/kb/Safe+Mode
> then try a new profile:
> http://support.mozilla.com/en-US/kb/Managing+Profiles
> further info:
> http://support.mozilla.com/en-US/kb/Basic+Troubleshooting

Comment 3

8 years ago
(In reply to comment #2)
> I don't really know what that means - I'm techno-competant, but not
> techno-savy... can you explain why you mean by the "details" button?

The button you pressed that gave you the text that you pasted into the description for this bug was labeled "details" in the crash reporter window. What you pasted up there isn't what we need. (everything from "Add-ons:" through "This report also contains technical information about the state of the
application when it crashed.") You need to give us your crash ID that lets us look up the so-called "technical information" it mentions it sent. Please read the instructions linked to in comment 1 and post a few crash IDs for this.
go to about:crashes in your address bar, and then past the ids from the time corresponding to your crash.
(Reporter)

Comment 5

8 years ago
Thank you for your help. I got the Crash ID and will troubleshoot as soon as I can. But here is the Crash ID for the time being:

Crash ID: bp-37a1ef33-f2ba-4392-83f0-ace2c2090903



(In reply to comment #3)
> (In reply to comment #2)
> > I don't really know what that means - I'm techno-competant, but not
> > techno-savy... can you explain why you mean by the "details" button?
> The button you pressed that gave you the text that you pasted into the
> description for this bug was labeled "details" in the crash reporter window.
> What you pasted up there isn't what we need. (everything from "Add-ons:"
> through "This report also contains technical information about the state of the
> application when it crashed.") You need to give us your crash ID that lets us
> look up the so-called "technical information" it mentions it sent. Please read
> the instructions linked to in comment 1 and post a few crash IDs for this.

Comment 6

8 years ago
bp-37a1ef33-f2ba-4392-83f0-ace2c2090903
0  	xul.dll  	nsDocShell::SetupNewViewer  	 docshell/base/nsDocShell.cpp:6717
1 	xul.dll 	nsDocShell::Embed 	docshell/base/nsDocShell.cpp:5139
2 	xul.dll 	nsDocShell::CreateContentViewer 	docshell/base/nsDocShell.cpp:6430
3 	xul.dll 	nsDSURIContentListener::DoContent 	docshell/base/nsDSURIContentListener.cpp:138
4 	xul.dll 	nsDocumentOpenInfo::TryContentListener 	uriloader/base/nsURILoader.cpp:736
5 	xul.dll 	nsDocumentOpenInfo::DispatchContent 	uriloader/base/nsURILoader.cpp:434
6 	xul.dll 	nsDocumentOpenInfo::OnStartRequest 	uriloader/base/nsURILoader.cpp:280
7 	xul.dll 	nsBaseChannel::OnStartRequest 	netwerk/base/src/nsBaseChannel.cpp:665
8 	xul.dll 	xul.dll@0x8ac003 	
9 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:395
10 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:111
11 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:510
12 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
13 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:193
14 	nspr4.dll 	PR_GetEnv 	
15 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:110
16 	firefox.exe 	firefox.exe@0x21a7 	
17 	kernel32.dll 	BaseThreadInitThunk 	
18 	ntdll.dll 	__RtlUserThreadStart 	
19 	ntdll.dll 	_RtlUserThreadStart

Appears to be bug 434403.

Primary cause is a trojan on your system. Support article is here:
http://support.mozilla.com/en-US/kb/Firefox+crashes+when+you+open+it#Backdoor_Ulrbot_C
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Summary: I always experience a crash anytime I try to open a browser → I always experience a crash anytime I try to open a browser [@nsDocShell::SetupNewViewer(nsIContentViewer*) ]
Duplicate of bug: 434403
(Reporter)

Comment 7

8 years ago
Thank you for your help. I got the Crash ID and will troubleshoot as soon as I
can. But here is the Crash ID for the time being:

Crash ID: bp-37a1ef33-f2ba-4392-83f0-ace2c2090903



(In reply to comment #3)
> (In reply to comment #2)
> > I don't really know what that means - I'm techno-competant, but not
> > techno-savy... can you explain why you mean by the "details" button?
> The button you pressed that gave you the text that you pasted into the
> description for this bug was labeled "details" in the crash reporter window.
> What you pasted up there isn't what we need. (everything from "Add-ons:"
> through "This report also contains technical information about the state of the
> application when it crashed.") You need to give us your crash ID that lets us
> look up the so-called "technical information" it mentions it sent. Please read
> the instructions linked to in comment 1 and post a few crash IDs for this.

Comment 8

8 years ago
chmehico.dll

Comment 9

7 years ago
The problem occurs when you upgrade to version 2.x to 3.x. Currently I am using version 2.X because I can not use the 3.X on account of this problem.
You need to log in before you can comment on or make changes to this bug.