Last Comment Bug 514503 - NJ: Add sanity check filter
: NJ: Add sanity check filter
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 457879 513844 514548
  Show dependency treegraph
 
Reported: 2009-09-03 12:36 PDT by David Anderson [:dvander]
Modified: 2011-10-31 12:02 PDT (History)
5 users (show)
sayrer: wanted1.9.2+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta1-fixed


Attachments
sanity checker (3.31 KB, patch)
2009-09-03 12:36 PDT, David Anderson [:dvander]
edwsmith: review+
gal: review+
Details | Diff | Splinter Review

Description David Anderson [:dvander] 2009-09-03 12:36:18 PDT
Created attachment 398443 [details] [diff] [review]
sanity checker

This is right from CodegenLIR.cpp for the most part. Blocking our x64 port because we had a bajillion typing errors so I think it's important for us to turn this thing on all the time.
Comment 1 Andreas Gal :gal 2009-09-03 15:39:33 PDT
Comment on attachment 398443 [details] [diff] [review]
sanity checker

Stealing this from Ed. This moves CodeGen.cpp code into nanojit where we can share it with Adobe. I am sure he is ok with that.
Comment 2 Edwin Smith 2009-09-03 18:06:23 PDT
Comment on attachment 398443 [details] [diff] [review]
sanity checker

Cool, but why not just promote the whole ValidateWriter from CodegenLIR.cpp?  I like the new name SanityFilter, and there's nothing in ValidateWriter that should be Tamarin specific.
Comment 3 Edwin Smith 2009-09-03 18:08:16 PDT
(In reply to comment #0)
> Created an attachment (id=398443) [details]
> sanity checker
> 
> This is right from CodegenLIR.cpp for the most part. Blocking our x64 port
> because we had a bajillion typing errors so I think it's important for us to
> turn this thing on all the time.

yeah, this thing saved me many many man hours of debugging time.

jseward was prototyping an even smarter type checker that could replace this one down the road.
Comment 4 David Anderson [:dvander] 2009-09-04 17:58:18 PDT
http://hg.mozilla.org/tracemonkey/rev/4334662cc4de

I was trying to take a minimal subset - will do a follow-up patch for the rest next week.
Comment 5 Blake Kaplan (:mrbkap) 2009-09-16 17:15:32 PDT
http://hg.mozilla.org/mozilla-central/rev/4334662cc4de -- I read comment 4 as this not being FIXED.

Note You need to log in before you can comment on or make changes to this bug.