Mozilla Crashes when it doesn't recognize a doctype DTD

VERIFIED DUPLICATE of bug 50994

Status

()

P3
critical
VERIFIED DUPLICATE of bug 50994
18 years ago
18 years ago

People

(Reporter: mozilla, Assigned: rickg)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
At the web site http://www.psu.edu/ur/directory/ mozilla crashes everytime.
After some snooping I found the following line was the culprit...

<!DOCTYPE HTML PUBLIC "-//SoftQuad Software//DTD HoTMetaL PRO
6.0::19990601::extensions to HTML 4.0//EN" "hmpro6.dtd">

When I remove the line, the page loads fine. I guess that this line might be bad
HTML in comparison with the rest of the page, but mozilla should either ignore
it if it doesn't understand, or present an error. It should most definately not
crash with an invalid page fault in gkparser
(Reporter)

Comment 1

18 years ago
oops. I didn't realize that my first post actually made it through (network
problems on my end.) I'm marking my own post a duplicate


*** This bug has been marked as a duplicate of 50994 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
This is a duplicate of bug 50994:Crashing in nsCParserNode::GetNodeType, with
strict DOCTYPE and unclosed tags
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.