"ASSERTION: subshell not in the map" with onunload, iframe, contenteditable

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 3 bugs, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 398777 [details]
testcase (triggers assertion when closed)

###!!! ASSERTION: subshell not in the map: 'shellContent', file docshell/base/nsDocShell.cpp, line 4506

(Bug 292970 and bug 186675 also mention this assertion, but I can't reproduce them.)
(Reporter)

Comment 1

9 years ago
Created attachment 398779 [details]
stack trace
(Reporter)

Comment 2

9 years ago
WFM.  I tried closing the tab, closing the window, and navigating away.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Flags: in-testsuite?
(Reporter)

Comment 3

9 years ago
Test checked in: http://hg.mozilla.org/mozilla-central/rev/08cb6bce6d83
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.