Last Comment Bug 514804 - gfxPlatform::GetRenderingIntent returns an int, not a bool
: gfxPlatform::GetRenderingIntent returns an int, not a bool
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: GFX: Color Management (show other bugs)
: Trunk
: x86 Mac OS X
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-04 20:05 PDT by Bobby Holley (:bholley) (busy with Stylo)
Modified: 2011-10-07 15:39 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Bobby Holley (:bholley) (busy with Stylo) 2009-09-04 20:05:32 PDT
http://mxr.mozilla.org/mozilla-central/source/gfx/thebes/src/gfxPlatform.cpp#505

I just went through my moco inbox and taras' script was yammering at me. Looks like this works because PRBool is typedefed to an int. Should be fixed though, if only for the sake of not giving false positives to static analysis.
Comment 1 Benoit Girard (:BenWa) 2011-10-07 15:39:08 PDT
This has been changed to an int now, closing. This was likely fixed by the PRBool conversion.

Note You need to log in before you can comment on or make changes to this bug.