"Composing" search sort order in bug list from different columns does not work

RESOLVED DUPLICATE of bug 510944

Status

()

Bugzilla
Query/Bug List
RESOLVED DUPLICATE of bug 510944
9 years ago
9 years ago

People

(Reporter: Vitaliy Filippov, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15 Version/10.10
Build Identifier: Bugzilla 3.4.1

If you click column headers on the bug list table page in the direct order, the sort order does not compose from these columns.
However, if you click columns in the reverse order: OS->Priority->Severity, the sort order composes.
"direct" means "from left to right in table header".
"reverse" means "from right to left in table header".
The bug is in list/table.html.tmpl, and patch is included.

Reproducible: Always

Steps to Reproduce:
1. Go to any search, for example My Bugs
2. Click "ID" column header, look at URL: order will be "order=bug_id"
3. Click "Severity" column header, look at URL: order will be "order=bug_severity"
4. Click "Priority" column header, look at URL: order will be "order=priority"
5. Click "OS" column header, look at URL: order will be "order=op_sys"

And so on.
Actual Results:  
Described in Steps to reproduce.

Expected Results:  
After step 4, sort order must be order=priority,severity
After step 5, sort order must be order=op_sys,priority,severity
And so on.
I.e. a new column must be added to sort order at every click to different column.
(Reporter)

Comment 1

9 years ago
Created attachment 399042 [details] [diff] [review]
Patch fixing current bug
(Reporter)

Comment 2

9 years ago
Hmm.. probably this bug is a duplicate of Bug 510944.
Also, it's fixed by Bug 164009.
Voted for Bug 164009.

Comment 3

9 years ago
Should be fixed by bug 510944.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 510944
You need to log in before you can comment on or make changes to this bug.