Closed Bug 515171 Opened 12 years ago Closed 10 months ago

Some websites return HTTP 501 error if the UA is 'rm'

Categories

(Tech Evangelism Graveyard :: Other, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: stas, Unassigned)

References

Details

When the user agent string indicates 'rm' as browser's locale, some websites do not work properly. They return 501 Not Implemented or 404. Examples:
http://stadt-zuerich.ch/
http://www.opensourcecms.com/demo/1/10/CMS_Made_Simple

Possibly related are these pages not loading their CSS:
http://www.eisenwerk.ch/
http://ckeditor.com/fckeditor-old-site

Our Romansh localizer, Gion-Andri, provides more details:
> I've found two types off errors:
> -first, some pages show an error when visiting with the romansh firefox:
> Method Not Implemented
> GET to / not supported.
> This are pages like
> http://stadt-zuerich.ch/
> http://www.opensourcecms.com/demo/1/10/CMS_Made_Simple
> 
> -second, there are pages that show error messages and no css styles. like
> http://www.eisenwerk.ch/
> http://ckeditor.com/fckeditor-old-site
> 
> I don't know exactly if it's the same error.
> I've installed the extension "modify headers" 
> (https://addons.mozilla.org/de/firefox/addon/967). When I'm changing the 
> user-agent to
> " Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.1) ", all 
> this pages are working correctly.

Filing this under Mozilla Localizations for initial triage.
Moving over to tech evang.

I contacted Stadt Zuerich for now.
Assignee: nobody → other
Component: rm / Romansh → Other
OS: Mac OS X → All
Product: Mozilla Localizations → Tech Evangelism
QA Contact: romansh.rm → other
Hardware: x86 → All
If this happens on multiple sites, we'll need specific TE bugs for each site.
Did you receive an answer from Stadt Zuerich? 

Another example is also the newspaper WOZ
http://www.woz.ch/
No, I didn't.
FWIW, on a few, I tested "rm-CH", no help. I also tested "ls", same issue, but "cat" is fine.
FWIW, "id" have same issue. Actually it's bug in modsecurity installation on Apache webserver, see https://www.modsecurity.org/tracker/browse/CORERULES-26 and http://ewesewes.web.id/2009/11/28/firefox-indonesia-and-http-error-501/
Depends on: 572656
Duplicate of this bug: 622486
Product: Tech Evangelism → Tech Evangelism Graveyard

This issue seems resolved in newer modsecurity versions. Closing this.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.