Closed Bug 515254 Opened 10 years ago Closed 4 years ago

trace-test/tests/sunspider/check-date-format-{tofte|xparb}.js fails due to requirement of PST/PDT TZ

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gal, Assigned: gal)

Details

No description provided.
We also fail trace-test/tests/sunspider/check-date-format-xparb.js.

Debugging the first failure now. Will file a second bug if its not the same cause.
Assignee: general → gal
What's the failure look like?  I'm seeing a problem with these two on x86 that seems related to daylight savings time (all the times are one hour off between March and November), it could be caused by my non-US locale so I'm not sure if I should file that as a separate bug.
I get the same output for -j and no -j on arm.
The ARM box was set to CST. Setting the timezone to PST (PDT) and setting the current time properly makes the failure go away. The fact that SS relies on the local time zone setting in a benchmark is an abomination. We should file a bug with Apple.
In the meantime, what do we do about trace-test?  I don't fancy changing my machine's time zones to PDT :(  I can just ignore them, it's annoying but I can live with it.
I think we will have to live with this for now. I don't want to add TZ-specific hacks to the test.
For those not on the North American west coast, add this:

  -x sunspider/check-date-format-xparb.js -x sunspider/check-date-format-tofte.js

to the trace-tests invocation to skip them.  Obviously this works best in a script or alias.
OS: Mac OS X → All
Hardware: x86 → All
No, the problem is clearly on our end. The actual SunSpider test (http://www2.webkit.org/perf/sunspider-0.9/date-format-tofte.html) does not contain the "expected" line that we have. That's something sayrer (I believe) added specifically for our check-date-format-*.js files.

Ubuntu is attempting to get `make check` done on all builds, so it's bad when tests like this fail just because the build machines are in a different TZ.
Summary: TM: we fail trace-test/tests/sunspider/check-date-format-tofte.js on TM tip [arm] → TM: trace-test/tests/sunspider/check-date-format-{tofte|xparb}.js fails due to requirement of PST/PDT TZ
pretty sure jorendorff fixed this
(In reply to comment #9)
> pretty sure jorendorff fixed this

When? Ubuntu just ran into this yesterday.

Doesn't look fixed on m-c based on lack of any commits about it in hg log:
http://mxr.mozilla.org/mozilla-central/source/js/src/trace-test/tests/sunspider/check-date-format-tofte.js
(The problem is "on our end" to the extent that we check that sunspider produces correct output, which sunspider otherwise cheerfully ignores, and to the extent that sunspider's behaviour varies according to which timezone you're in.)
(In reply to comment #11)
> http://hg.mozilla.org/tracemonkey/rev/4b5938c3b527

Cool.

check-date-format-tofte.js needs fixing, too, I believe, as per comment #7.
Looks like check-date-format-tofte.js still needs fixing?
http://mxr.mozilla.org/mozilla-central/source/js/src/jit-test/tests/sunspider/check-date-format-tofte.js#301
Summary: TM: trace-test/tests/sunspider/check-date-format-{tofte|xparb}.js fails due to requirement of PST/PDT TZ → trace-test/tests/sunspider/check-date-format-{tofte|xparb}.js fails due to requirement of PST/PDT TZ
I can't reproduce this any more, and I'm in ADST timezone which is a pretty good stress test.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.