Flash 10 produces "Movie not loaded" in Firefox 3.5+

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
3 years ago

People

(Reporter: m.klein, Unassigned)

Tracking

({flashplayer, qawanted, regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

After update to FF 3.5, certain flash movies are not loading. They worked fine in older FF, and still work in IE, Opera, and Chrome. The flash space is blank. Right click reveals Flash 10 "Movie not loaded" message.

Flash Version: WIN 10,0,32,18
Reproducable in FF 3.52 (no extensions) and in FF 3.7a1pre

I've tried various EMBED and OBJECT based methods to no avail. I've also tried various combinations of the movie URL, and also tried putting the movie into the same directory as the flash.

Example #1: http://www.adtprojekt.de/ (the light green box below the top menu)
Example #2: http://www.picdeutschland.de/ (the white space above the marquee)


Reproducible: Always

Steps to Reproduce:
1. Open example page http://www.picdeutschland.de/
2. See the blank space above the marquee
3. Right-Click there to reveal the Flash context menu stating "Movie not loaded"

Actual Results:  
Flash space remains blank, movie isn't loading, while it works in other browsers.

Expected Results:  
Flash movie should load.

There are many Flash bugs already, but I couldn't find any matching this specific problem. So I hope this is no double.
(Reporter)

Updated

9 years ago
Keywords: flashplayer
Version: unspecified → 3.5 Branch
Confirmed on Windows Vista, latest trunk.
Status: UNCONFIRMED → NEW
Component: Extension Compatibility → Plug-ins
Ever confirmed: true
Keywords: qawanted
Product: Firefox → Core
QA Contact: extension.compatibility → plugins
Version: 3.5 Branch → Trunk
Keywords: regression

Comment 2

9 years ago
This bug makes the Oracle support site (https://support.oracle.com) unusable.
(Reporter)

Comment 3

9 years ago
I've found out that it only appears to happen if the .swf is served with a content-disposition header. Removing that header will make the flash load.
(Reporter)

Comment 4

9 years ago
BTW the example pages will work now, because I've removed the disposition header there.

Comment 5

9 years ago
i'm moving this to the flash component, if it's actually our fault, their team will move it back.
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: Trunk → 10.x
So is there a site at this point that does show the problem?  I don't think we changed anything in particular with content-disposition... unless these are full-page plug-ins?
Though note that Flash 10 itself may now include checks for content-disposition and bail out to fix some security bugs...  and that other browsers might not provide it with the correct HTTP headers.

Comment 8

3 years ago
I'm closing a lot of bugs which are filed as Adobe Flash bugs which are either irrelevant, not actionable, or not serious enough to track in the Mozilla bug tracker. For the most part, Flash bugs should be filed in Adobe bugbase, and we'll only track a few highly-critical issues in the Mozilla tracker.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE

Comment 9

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.x → unspecified
You need to log in before you can comment on or make changes to this bug.