keyboard shortcuts from keyboard system preference do not take precedence (Command-Q still invokes Quit, even after successful shortcut key change for Quit Firefox menu)

RESOLVED DUPLICATE of bug 938303

Status

()

defect
RESOLVED DUPLICATE of bug 938303
10 years ago
5 years ago

People

(Reporter: jkatzer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: 3.5.2

i changed the keyboard shortcut for Quit Firefox in the system wide keyboard pane to one that is not command - q so that i do not hit it accidentally and close firefox.  i have also done this in the past with safari.  I would normally not conisder this a bug, BUT, it is certainly a deviation from being fully integrated with the host operating system.  This feature is widely used by power users, and I might assume the impaired as well.

Reproducible: Always

Steps to Reproduce:
 this setting is found under the system wide keyboard preference, and you can reproduce it by adding a new "application shortcut" just for firefox, where the menu name is called "Quit Firefox".  Then close(if open) and reopen firefox. 
Actual Results:  
Sure enough, under the firefox application menu, the new keyboard shortcut is there.  The problem is that firefox still closes when you hit command-q.

Expected Results:  
the software should no longer use its internal keyboard command, once overhauled by the system,

please feel free to email me at gmail with the username of jkatzer for any questions or screenshots.
also, i am using snow leopard, and have not tested this functionality with firefox on leopard, but i have on safari and leopard.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
(In reply to philippe (part-time) from comment #2)
> *** This bug has been marked as a duplicate of bug 429824 ***

This bug is for;
   newly assigned shortcut to "Quit Firefox" works pretty well as expected.
   Command-Q still invokes Quit, even after successfull shortcut change.

Bug 429824 is for problem of "new short cut doesn't work".
How can this bug be dup of bug 429824?
philippe, how did you veryfy that this bug is actually dup of bug 429824?

Re-opening, with setting dependency to bug 938303 for ease of problem analysis and tracking.
Status: RESOLVED → REOPENED
Depends on: 938303
Ever confirmed: true
Resolution: DUPLICATE → ---
Summary: keyboard shortcuts from keyboard system preference do not take precedence → keyboard shortcuts from keyboard system preference do not take precedence (Command-Q still invokes Quit, even after successful shortcut key change for Quit Firefox menu)
Problem will be fixed by bug 938303. Duping to that bug.
Status: REOPENED → RESOLVED
Closed: 10 years ago5 years ago
No longer depends on: 938303
Resolution: --- → DUPLICATE
Duplicate of bug: 938303
You need to log in before you can comment on or make changes to this bug.