blank tooltip displayed in empty area of bookmark sidebar

VERIFIED FIXED in Firefox 3.7a1

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: bws42, Assigned: Gabri)

Tracking

({regression})

Trunk
Firefox 3.7a1
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090910 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090910 Minefield/3.7a1pre

Open the bookmark sidebar, and close enough folders so there is some empty space at the bottom. If you leave your mouse still an empty popup will be displayed unless you've already hovered over another link then the link's tooltip will be displayed. The regression range is:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d32b4b3c29ac&tochange=3521b67756f6

Reproducible: Always
most likely regression from bug 244371.
Gabriele could you take a look at this?
Blocks: 244371
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20090910 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20090910045239.
Version: unspecified → Trunk
Keywords: regression
(Assignee)

Comment 3

8 years ago
Created attachment 400343 [details] [diff] [review]
patch
Assignee: nobody → gabri.best
Status: NEW → ASSIGNED
Attachment #400343 - Flags: review?(mak77)
Attachment #400343 - Flags: review?(mak77) → review+
http://hg.mozilla.org/mozilla-central/rev/f7aaf57c61e8

Thanks!!!
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1

Comment 5

8 years ago
Has something gone wrong with the checkin? It is empty.
wtf, yeah, thanks for the notification, not sure what happened, i'll check and re-push.
reopening so i won't forget to re-push, since the tree is actually quite orange.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 400744 [details] [diff] [review]
unbitrot
Attachment #400343 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/4f62bec2c7f9

This should be correct, sorry for the empty push.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
fixed on 1.9.2 along with bug 244371
status1.9.2: --- → beta1-fixed
verified with: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20091111 Minefield/3.7a1pre

and latest Windows Namoroka build
Status: RESOLVED → VERIFIED
(Assignee)

Updated

8 years ago
Depends on: 529113
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Blocks: 529113
No longer depends on: 529113
You need to log in before you can comment on or make changes to this bug.