Closed Bug 516108 Opened 11 years ago Closed 11 years ago

Web folders not read properly - images not displayed - All okay before latest release

Categories

(Firefox :: Address Bar, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: david.cgl, Unassigned)

References

()

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; DigExt; .NET CLR 2.0.50727; .NET CLR 1.1.4322; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.14) Gecko/2009082707 Firefox/3.0.14 (.NET CLR 3.5.30729)

Web page http://www.hookertactical.com/1Fil/W1_Bullets.htm is now being read as
http://www.hookertactical.com/1Fil\W1_Bullets.htm when the "Bullets/Ammunition" hyperlink is clicked.
NOTE1: The forward slant before the W1 has been replaced by a backward slant, making it an incorrect URL.  Because of this problem, the images are not displayed.  Before this release, Firefox displayed the Hooker Tactical web pages correctly (with images).
NOTE2: When the correct URL is entered manually i.e. http:/www.hookertactical.com/1Fil/1W_Bullets.htm the page displays correctly with its images.

Reproducible: Always

Steps to Reproduce:
1.Go to Home page http://www.hookertactical.com/Default.htm
2.Click on "Bullets/Ammunition hyperlink button.
3.URL address is http://www.hookertactical.com/1Fil\W1_Bullets.htm
4.View page with missing images and incorrect URL.
5.Correct URL to http://www.hookertactical.com/1Fil/1W_Bullets.htm
6.Note that page displays properly with images.
Actual Results:  
1.  When "Bullet/Ammunition" hyperlink button is clicked Firefox goes to the URL address of http://www.hookertactical.com/1Fil\W1_Bullets.htm
2.  The text of the page is displayed but the images are not.

Expected Results:  
1.  When "Bullet/Ammunition" hyperlink button is clicked Firefox should go to the URL address of http://www.hookertactical.com/1Fil/W1_Bullets.htm
2.  The text of the page should be displayed as well as the images.
Confirmed on Windows Vista, latest trunk. If I go to http://www.hookertactical.com/ and click on Bullets/Ammunition , the images are missing.

This is reproducible with all Firefox builds, also old ones like Firefox 1, but not with Opera and Google Chrome.
Status: UNCONFIRMED → NEW
Component: General → Location Bar and Autocomplete
Ever confirmed: true
QA Contact: general → location.bar
Version: unspecified → Trunk
This is a dupe of an invalid bug

The source code for that link:
<a href="1Fil%5CW1_Bullets.htm"><span style="color: black;">&nbsp;</span><b><span style="font-size: 14pt; color: black;">Bullets/Ammunition</span></b></a>

'%5C' is '\'. A URL cannot contain that character.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: backslash
You need to log in before you can comment on or make changes to this bug.