Closed Bug 516180 Opened 13 years ago Closed 3 years ago

Fennec should be able to save files via javascript just like Firefox does.

Categories

(Firefox for Android Graveyard :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: leeand00, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: fennec-1.0a3.en-US.wince-arm

When using software like tiddlywiki (www.tiddlywiki.com), Fennec should be able to rewrite the page back out to a storage medium.

No other mobile browsers have this feature and I would very much like to see it added to Fennec.

Reproducible: Always
Tiddlywiki's save/restore feature appears to work fine in the Fennec "emulator" (desktop linux build from hg tip).  I have not tested this yet on any mobile OS.
Long tap will show javascript:; Bookmark Link

selection of it will cause a slight graphic defect and bring up the App Helper.  It looks like it's looking for a file picker?
Blocks: 616348
Closing all opened bug in a graveyard component
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.