Save tabs on quit dialog doesn't save preferences

RESOLVED FIXED

Status

SeaMonkey
Tabbed Browser
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: bleahrimasu, Assigned: Misak Khachatryan)

Tracking

({fixed-seamonkey2.0})

Trunk
x86
Windows XP
fixed-seamonkey2.0
Dependency tree / graph
Bug Flags:
blocking-seamonkey2.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 515006 checkin.)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090913 SeaMonkey/2.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090913 SeaMonkey/2.0pre

Seamonkey does not follow the behaviour expected in the save tabs on quit dialog.

Reproducible: Always

Steps to Reproduce:
1. Quit browser with tabs open.
2. The save tabs on quit dialog appears("Do you want Seamonkey to save your tabs for the next time it starts?")
3. Select "Do not ask next time", then press quit.
4. Restart browser, open multiple tabs. Quit browser.
Actual Results:  
The dialog triggers again, even when "Do not ask next time" is selected the previous time.

Expected Results:  
On selecting "Do not ask next time", the dialog should NEVER be triggered when quitting subsequent multi-tabbed browser sessions.

Updated

8 years ago
Flags: blocking-seamonkey2.0?
Confirming with Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090910 SeaMonkey/2.0pre

You need File - Exit to get this dialog.
Status: UNCONFIRMED → NEW
Ever confirmed: true
In the dialog in nsSuiteGlue.js "browser.tabs.warnOnClose" is set to false, shouldn't we set "browser.warnOnQuit" instead?

Misak, any ideas?
Blocks: 36810
(Reporter)

Comment 3

8 years ago
You can get this dialog through Ctr-Q as well.

Bug still exists with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090913 SeaMonkey/2.0pre
(Assignee)

Comment 4

8 years ago
(In reply to comment #2)
> In the dialog in nsSuiteGlue.js "browser.tabs.warnOnClose" is set to false,
> shouldn't we set "browser.warnOnQuit" instead?

This line should be deleted, we will not set "browser.tabs.warnOnClose" to false in this case. The cause of this behavior a little bit above:

      if (prefBranch.getBoolPref("browser.warnOnQuit") == false)
        showPrompt = false;

The fix is a part of bug 515006 patch, which in process of review. I'll talk with Neil, maybe better to separate that and publish here.
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Assignee: nobody → misak

Comment 5

8 years ago
This is annoying enough to a number of users that we shouldn't ship 2.0 with this behavior. Misak, independent if bug 515006 makes it, could we get the issue talked about here fixed, or does this depend on the other one?
Flags: blocking-seamonkey2.0? → blocking-seamonkey2.0+
Version: unspecified → Trunk
(Assignee)

Comment 6

8 years ago
Patch landed:

http://hg.mozilla.org/comm-central/rev/b9f6a5af7814
http://hg.mozilla.org/comm-central/rev/631b2247f293
(Assignee)

Comment 7

8 years ago
Can't reproduce it after bug 515006 landing, resolving as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Depends on: 515006
Resolution: --- → FIXED
Whiteboard: fixed by bug 515006 checkin.

Updated

8 years ago
Keywords: fixed-seamonkey2.0
(Reporter)

Comment 8

8 years ago
Sorry, I'm still seeing the behaviour in the latest build (Gecko/20090926 SeaMonkey/2.0pre), even though I've deleted all instances of "WarnOn" and "tabs" in prefs.js

Do I need to attach my prefs.js file for someone to look at?
(Reporter)

Comment 9

8 years ago
1. Download latest nightly (Gecko/20090926 SeaMonkey/2.0pre)
2. Create new user profile
3. Start browser.
4. Open multiple tabs.
5. Close browser window by Alt+F4 or Ctrl+Q
6. Dialogue pops up. Select do not ask next time, click Quit.
7. Repeat 3-5.
8. Expected behaviour: dialogue should not pop up again. But it does.

Comment 10

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090926 SeaMonkey/2.0pre - Build ID: 20090926001533


NOT fixed. 

Happening here as well.
(Assignee)

Comment 11

8 years ago
Well, it's not working if you hit quit button and working if you hit quit and save. Investigating ...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

8 years ago
Created attachment 403106 [details] [diff] [review]
add missing prefs [Checkin: Comment 13]

OK, code below is good:

      if (prefBranch.getIntPref("browser.startup.page") == 3 ||
          prefBranch.getBoolPref("browser.sessionstore.resume_session_once") ||
          !prefBranch.getBoolPref("browser.warnOnQuit"))
        showPrompt = false;
      else if (aQuitType == "restart")
        showPrompt = prefBranch.getBoolPref("browser.warnOnRestart");
      else
        showPrompt = prefBranch.getBoolPref("browser.tabs.warnOnClose");

but it throws because we don't have "browser.warnOnRestart" and "browser.warnOnQuit". Adding them.
Attachment #403106 - Flags: superreview?(neil)
Attachment #403106 - Flags: review?(neil)

Updated

8 years ago
Attachment #403106 - Flags: superreview?(neil)
Attachment #403106 - Flags: superreview+
Attachment #403106 - Flags: review?(neil)
Attachment #403106 - Flags: review+
(Assignee)

Updated

8 years ago
Attachment #403106 - Flags: approval-seamonkey2.0?
(Assignee)

Updated

8 years ago
Keywords: checkin-needed

Updated

8 years ago
Attachment #403106 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+

Comment 13

8 years ago
Comment on attachment 403106 [details] [diff] [review]
add missing prefs [Checkin: Comment 13]

http://hg.mozilla.org/comm-central/rev/adb01e467963
Attachment #403106 - Attachment description: add missing prefs → add missing prefs [Checkin: Comment 13]

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.