Closed Bug 517092 Opened 11 years ago Closed 9 years ago

Diagonal scrolling around scaled images slow

Categories

(Core :: Graphics, defect)

1.9.2 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: glenn, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

When a large image is scaled, scrolling diagonally is very slow.


Reproducible: Always

Steps to Reproduce:
1. Open a large, scaled image: http://zewt.org/~glenn/scaled-image.html
2. Scroll with the scrollbars.  Scrolling is smooth.
3. Middle-click on the document, and smooth scroll vertically.  Scrolling is smooth.
3. Middle-click on the document, and scroll diagonally.  Scrolling is slow and extensive redraw is visible.




Related: bug 246393, bug 443264.  I think both of those are fixed; diagonal scrolling an image at 1:1 is just as fast for me as scrolling on one axis.

I think it's just dropping out of the fast path when scaling and diagonal scrolling are combined.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090915 Shiretoko/3.5.4pre

Vertical scrolling takes 1 second and diagonally scrolling 2 seconds.
Version: unspecified → 1.9.1 Branch
Product: Core → Core Graveyard
Component: Image: Painting → Graphics
Product: Core Graveyard → Core
QA Contact: image.gfx → thebes
Still happens in 3.6.3.
Version: 1.9.1 Branch → 1.9.2 Branch
Not that anybody seems to be listening, but closing this since this seems to be fixed in FF4.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.