Closed Bug 517156 Opened 11 years ago Closed 9 years ago

Prevent multiple timer manager timers from firing on the first timer notification after startup

Categories

(Toolkit :: Application Update, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 604804

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

Details

spinoff of bug 471219

I think the cleanest / safest way to do this is to enumerate all timers approximately 1/2 way through the first app.update.timer interval and reset their last update time to a notification slot that isn't used by another timer.
Assignee: nobody → robert.bugzilla
Depends on: 604804
Fixed as part of bug 604804
Status: NEW → RESOLVED
Closed: 9 years ago
No longer depends on: 604804
Resolution: --- → DUPLICATE
Duplicate of bug: 604804
You need to log in before you can comment on or make changes to this bug.