Randomly stops loading any page (affects all tabs), process refuses to close/quit

RESOLVED DUPLICATE of bug 470849

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 470849
8 years ago
8 years ago

People

(Reporter: spamishorrible, Unassigned)

Tracking

3.5 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

This has been happening to me for about 3 to 4 months now, sometimes as much as 3 times per day (new versions have not fixed this issue, persists on new installation of Windows Vista and new FF profile).

I will have multiple tabs open, and able to navigate to any page on the internet. I will click on a new link, the page goes blank, and there is no "loading" or progress bar at the bottom. Sometimes the bottom left corner will say "Stopped." Reload/refresh will not elicit any feedback at all. Switching to other tabs and trying to load new pages (or reload those tabs) will not work (tabs just say "Loading..." with the loading circle thing. Closing FF will hide the window, but process persists in Task Manager. Attempts to kill the process fail; FF refuses to quit. The only way to quit it is to force-shutdown the computer (holding power button; software shutdown hangs because FF refuses to release resources).

I have tried disabling all my addons, and that has had no effect.

Reproducible: Sometimes

Steps to Reproduce:
1. Have multiple tabs open
2. Browse to anywhere
3. Page will go blank, refuse to load anything
4. Try to reload other tabs.
5. Try to quit FF.
Actual Results:  
FF fails to reload other tabs. Trying to quit FF (kill process) fails; FF refuses to release resources.

Expected Results:  
Not fail to load a page. At the very least, it should release the resources when Windows tells it to.

No extra themes installed. Addons include Adblock Plus, Greasemonkey, Google Redesigned, Firebug, Download Statusbar, Session Manager.

Does not trip a real crash, so no crash reports filed. No errors/warnings/messages in console.

A friend of mine has had this issue, as well. He remembers hearing something about a bug in GTK that wasn't going to be fixed anytime soon, but don't quote me on that.
So you have reinstalled Windows and did you do a clean Firefox reinstallation and did you use a profile without extensions?
Have you already tried the options here: http://support.mozilla.com/en-US/kb/Firefox+Hangs ?
Not being able to end the program in the task manager sounds very weird, is mostly not caused by Firefox itself but by a third party program or by a driver.
Note that this is a bugs database for developers and you will probably find better support here: http://support.mozilla.com/en-US/kb/Ask+a+question
Version: unspecified → 3.5 Branch
Do you have Zonealarm installed ?
It can not be Firefox fault if you can not kill the process, Firefox hangs in kernel mode code like a Firewall driver. That Firefox stops loading pages is the same issue and seems to point to a firewall driver.
(Reporter)

Comment 3

8 years ago
Indeed, I do have Zonealarm. However, I never related it as causing the problem (did a whole lot of searching online, couldn't find anything). A quick search relating it to ZA came up with some answers.

Thanks for your help guys!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470849
You need to log in before you can comment on or make changes to this bug.