Closed Bug 517741 Opened 11 years ago Closed 11 years ago

cold startup regression in 3.6

Categories

(Firefox :: General, defect, P1)

3.6 Branch
x86
Windows NT
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
status1.9.2 --- wontfix

People

(Reporter: dietrich, Assigned: dietrich)

Details

(Keywords: perf, regression, Whiteboard: [ts])

Attachments

(1 file)

in our startup measurement work, we found a clear regression in cold startup time on windows between 3.5 and 3.6 (and somewhat less so in 3.7).

the summarized numbers are here:

https://wiki.mozilla.org/Firefox/Projects/Startup_Time_Improvements#Overview

drew noticed it, i reproduced on win7, and then tony reproduced on xp.

we need to find out exactly what caused the regression, and then can work from there. if anyone has cycles to do cold-startup testing of windows builds to figure out a regression range, that'd be amazing.
requesting blocking: it's a huge (~36% on win7) regression in cold startup time from 3.5 to 3.6.
Flags: blocking-firefox3.6?
Whiteboard: [ts]
Version: Trunk → 3.6 Branch
Flags: blocking-firefox3.6? → blocking-firefox3.6+
taking, will find and reassign to regressor.
Assignee: nobody → dietrich
i ran a bunch of cold startup tests today, trying to find the regression window, and could not reproduce the problem. can someone from QA confirm the regression and try to find the window? I tested builds from 8/13, 9/1, 9/9 before re-testing 3.5 only to find that I could no longer reproduce the regression.

note: i tried disabling superfetch, which seemed to give a bit more stable numbers: http://www.howtogeek.com/howto/windows-vista/how-to-disable-superfetch-on-windows-vista/
Keywords: qawanted
Thanks Juan. Summary of these numbers:

3.6 median .5% improvement over 3.5
3.6 average 8% improvement over 3.5

3.7 median 27% improvement over 3.5
3.7 average 30% improvement over 3.5

Resolving WFM since we can't reproduce in historical nor contemporary builds.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Another WinXP data point...

3.5.3 cold:
10837
11381
12707

3.6a2 (34da890d632d) cold:
9332
9352
8713
great, thanks for confirming Michael.
You need to log in before you can comment on or make changes to this bug.