Port Bug 223132: need a scrollbar on the envelope panel (view all headers / long address lists)

RESOLVED FIXED in seamonkey2.0

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

(Blocks: 1 bug, {fixed-seamonkey2.0})

Trunk
seamonkey2.0
fixed-seamonkey2.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
+++ This bug was initially created as a clone of Bug #223132 +++

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/85.7 (KHTML, like Gecko) Safari/85.5
Build Identifier: thuderbird 20031013

sometimes a mail header has a lot of lines, many more than can fit into the window currently 
showing the mail headers (when you do a view all headers).
the problem is there is no way to scroll down the headers to see them all, and sometimes even 
maximizing the window doesn't show them all.
can you add a scrollbar to this area?

Reproducible: Always

Steps to Reproduce:
1. find an email with a lot of headers
2. view all headers
3. you can't see them all


Expected Results:  
put a scroll bar there 

workaround is to view message source
(Assignee)

Comment 1

8 years ago
Created attachment 401889 [details] [diff] [review]
Patch v1.0 Wallpaper over the problem until something better comes along.

I hope putting this in content/ rather than skin/ is OK.
Attachment #401889 - Flags: superreview?(neil)
Attachment #401889 - Flags: review?(mnyromyr)

Comment 2

8 years ago
Comment on attachment 401889 [details] [diff] [review]
Patch v1.0 Wallpaper over the problem until something better comes along.

r/moa/a=me
Attachment #401889 - Flags: superreview?(neil)
Attachment #401889 - Flags: superreview+
Attachment #401889 - Flags: review?(mnyromyr)
Attachment #401889 - Flags: review+
Attachment #401889 - Flags: approval-seamonkey2.0+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed

Comment 3

8 years ago
So, this will introduce the issues mentioned in bug 511408 to SeaMonkey as well? The header pane may be too small now when varying number of headers are shown in sequence. Expanding to a specific size before showing the scrollbar would be the optimum case IMO...
(Assignee)

Comment 4

8 years ago
Yes, this isn't optimal - but it's better than the previous situation; that's why I said "until something better comes along".

Comment 5

8 years ago
http://hg.mozilla.org/comm-central/rev/1249166e9ad2
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed → fixed-seamonkey2.0
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0

Updated

8 years ago
Blocks: 522278

Comment 6

8 years ago
Since apparently Thunderbird won't come up with a nice fix in bug 511408 any time soon, I've spun off bug 522278 to find a feasible solution for SeaMonkey. It's good to have the scroll bar now, but it shouldn't show up until max-height is fully utilized.
You need to log in before you can comment on or make changes to this bug.