context menu for URLs that are not linked should include the full link context menu

RESOLVED DUPLICATE of bug 720023

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 720023
9 years ago
6 years ago

People

(Reporter: eyal gruss (eyaler), Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

recently bug 454518 was fixed to allow opening URLs that are not linked from
the context menu. while the new context menu items allow opening the link, we do not get the full link context menu (bookmark, save, send, etc.). this also means that add-on actions on links such as "open in ie tab" will not be available.



Reproducible: Always

Steps to Reproduce:
1. select unlinkified url
2. right click selection
3.
Actual Results:  
no items for bookmark link, save link as, etc.

Expected Results:  
all items appearing on the link context menu should be available
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
(Reporter)

Updated

9 years ago
Depends on: 454518
I don't really know what can be done here, adding all the link context menu items seems unwise as it will seriously clutter the context menu, and we /may/ be wrong in assuming it's what the user wants (to open the link). Asking for uiwanted...
Keywords: uiwanted
OS: Windows XP → All
Hardware: x86 → All
(In reply to Nochum Sossonko [:Natch] from comment #1)
> I don't really know what can be done here, adding all the link context menu
> items seems unwise as it will seriously clutter the context menu, and we
> /may/ be wrong in assuming it's what the user wants (to open the link).
> Asking for uiwanted...

I agree. This will indeed clutter the context menu. I can see that to be an add-on.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: uiwanted
Resolution: --- → WONTFIX

Updated

6 years ago
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 720023
You need to log in before you can comment on or make changes to this bug.