nsIWebbrowserFind entireWord attribute doesn't work when its value is set to True

RESOLVED DUPLICATE of bug 269442

Status

()

Core
Find Backend
RESOLVED DUPLICATE of bug 269442
8 years ago
3 years ago

People

(Reporter: shum_bin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: xulrunner 1.9.1.3

I am experimenting on xpcom using vb.net, much like geckofx but which is using c#.

The testing application simply navigates to an html file on local disk and perform a findNext() using the nsIWebbrowserFind interface. All attributes of the interface except entireWord are working great. The value of entireWord is set successfully to True. But still the function locates the "is" inside "this" as a match, as if it always uses the value of False.

Because only this single attribute value is not working, it is most likely a bug, rather than an issue with the app.

Reproducible: Always

Steps to Reproduce:
1.need an app embedding mozilla via xpcom
2.navigate to any html file
3.perform a findNext() using nsIWebbrowserFind interface with entireWord=True, searchString="is"
Actual Results:  
finds & highlights "is" inside "this"

Expected Results:  
should skip "this"

The definition of the interface used in the testing app is like this :

<Guid("2f977d44-5485-11d4-87e2-0010a4e75ef2"), ComImport(), InterfaceType(ComInterfaceType.InterfaceIsIUnknown)> _
	Friend Interface nsIWebBrowserFind ' frozen
		Function findNext() As Boolean
		Sub searchStringGet(<MarshalAs(UnmanagedType.LPWStr)> ByVal aValue As String)
		Sub searchStringSet(<MarshalAs(UnmanagedType.LPWStr)> ByVal aValue As String)
		Sub findBackwardsGet(ByVal aValue As Boolean)
		Sub findBackwardsSet(ByVal aValue As Boolean)
		Sub wrapFindGet(ByVal aValue As Boolean)
		Sub wrapFindSet(ByVal aValue As Boolean)
		Sub entireWordGet(ByVal aValue As Boolean)
		Sub entireWordSet(ByVal aValue As Boolean)
		Sub matchCaseGet(ByVal aValue As Boolean)
		Sub matchCaseSet(ByVal aValue As Boolean)
		Sub searchFramesGet(ByVal aValue As Boolean)
		Sub searchFramesSet(ByVal aValue As Boolean)
	End Interface
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 14871
Duplicate of bug: 269442
You need to log in before you can comment on or make changes to this bug.