Closed Bug 518093 Opened 12 years ago Closed 12 years ago

Github.com pages with many lines of source code only partially rendered

Categories

(Firefox :: General, defect)

x86
Windows Server 2003
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 215055

People

(Reporter: sven_nilsson, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

When visiting the provided link, the browser seems to scroll to the correct anchor position (line #2870). However, no source code is displayed (a blank page). After scrolling up to the beginning of the page, the source code lines appear, but not all of them (only the first ~2000 lines).

Reproducible: Always

Steps to Reproduce:
1. Visit provided link
2. (optional) Scroll to top
3. (optional) Try to scroll down to line 2870
Actual Results:  
A blank page appears

Expected Results:  
Source code appears, with line 2870 highlighted

When referencing a lower line number, the code appears, but still only the first ~2000 lines. See this example, referencing line 287 instead of 2870.
http://github.com/spring/spring/blob/9a9023a1b4c849911e116bb92e3142ef7b17c595/rts/Lua/LuaSyncedCtrl.cpp#L287
Is fixed on trunk.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: big-long-large-32767
You need to log in before you can comment on or make changes to this bug.