Rename "waitFor" class to "waitForEvents"

VERIFIED FIXED

Status

VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-doc-needed][mozmill-1.2.2])

Attachments

(2 attachments)

Created attachment 402072 [details] [diff] [review]
Patch v1

Mikeal has added the waitFor class because he used it in bug 489474 to wait for events to occur. The name itself doesn't tell anything about this function and should be renamed to better reflect the feature behind it.

This patch renames the class and makes it accessible via waitForEvents.
Attachment #402072 - Flags: review?(ctalbert)
Blocks: 489474
Whiteboard: [mozmill-doc-needed][mozmill-1.2.2?]
Duplicate of this bug: 503487

Comment 2

10 years ago
I don't see you changing any of the consumers of this API, so this patch looks incomplete.  It looks like you are landing the tests in bug 489474 today...are you changing this API in those tests before landing?
No, the video test will not land today. I have some problems with current regressions and have to do some updates. So I will update those later. AFAIK those are the only tests which make use of the waitFor call. Do you know others?
Clint, ping?

Updated

10 years ago
Attachment #402072 - Flags: review?(ctalbert) → review+

Comment 5

10 years ago
Be sure to change the tests when they land. :)
Landed as http://github.com/mikeal/mozmill/commit/a0f6b75af414071969c45f46b86fcc5221a56504
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [mozmill-doc-needed][mozmill-1.2.2?] → [mozmill-doc-needed][mozmill-1.2.2]
With the landing of this patch we have a regression which makes this object unavailable.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 404460 [details] [diff] [review]
Follow-up

Changes in this patch which we definitely need for the next release:

* Changed usage to waitForEvents.init() and waitForEvents.wait()
* We should use an instance of waitForEvents as a member of MozMillController as we do for all the other functions. That's more consistent
* Throw a real error instead of a string when timeout happens
Attachment #404460 - Flags: review?(ctalbert)
Status: REOPENED → ASSIGNED
merged to mikeal/master
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Verified fixed based on changeset:
http://github.com/mikeal/mozmill/commit/2c9cbfeecd76659156a7836b50b7e68b8e7570fb
Status: RESOLVED → VERIFIED
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.