Last Comment Bug 518110 - nuke HTMLBaseFontElement interface
: nuke HTMLBaseFontElement interface
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: unspecified
: x86 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Jonas Sicking (:sicking) No longer reading bugmail consistently
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-22 07:08 PDT by Anne (:annevk)
Modified: 2010-04-19 12:10 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to fix (67.57 KB, patch)
2010-04-08 03:23 PDT, Jonas Sicking (:sicking) No longer reading bugmail consistently
jst: review+
Details | Diff | Splinter Review

Description Anne (:annevk) 2009-09-22 07:08:01 PDT
Opera recently removed rendering support for the <basefont> element to be in line with Gecko/WebKit, but the interface is still there because it is still in Gecko/WebKit. Would it be possible to clean this up or are we forever stuck with it? (I realize we're forever stuck with the quirk in the parser.)
Comment 1 Anne (:annevk) 2009-09-22 07:11:04 PDT
WebKit: https://bugs.webkit.org/show_bug.cgi?id=29641
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2010-04-08 03:23:53 PDT
Created attachment 437807 [details] [diff] [review]
Patch to fix

This patch does a few things

* Remove the nsIDOMHTMLBaseFontElement interface and tests for it.
* Remove (or rather make non-scriptable in order to preserve binary compat)
  nsIDOMHTMLHeadElement.profile. This is largely useless and I think it can
  be removed from the HTML5 spec.
* Kill nsHTMLHeadElement and nsHTMLHtmlElement. Instead use nsHTMLSharedElement
  for these element types.
* Remove apparently bogus comment about keeping classinfo ids stable
Comment 3 Johnny Stenback (:jst, jst@mozilla.com) 2010-04-15 17:22:08 PDT
Comment on attachment 437807 [details] [diff] [review]
Patch to fix

r=jst!
Comment 4 Jonas Sicking (:sicking) No longer reading bugmail consistently 2010-04-19 12:10:55 PDT
Checked in

http://hg.mozilla.org/mozilla-central/rev/3a2552c83446

Note You need to log in before you can comment on or make changes to this bug.