All users were logged out of Bugzilla on October 13th, 2018

IDNs aren't encoded properly when URL is sent from an external application

RESOLVED DUPLICATE of bug 530064

Status

()

RESOLVED DUPLICATE of bug 530064
9 years ago
9 years ago

People

(Reporter: aditya, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

If I click a link from an external application which is an IDN, like http://⌘am.ws/e/1587, Firefox doesn't encode it properly, hence breaking the URL, which means Firefox cannot navigate to the page.

Reproducible: Always

Steps to Reproduce:
1. Click a link with an IDN, e.g. http://⌘am.ws/e/1587 from an external application.
2. Firefox tries to open a garbled URL — www.%e2%8c%98am.ws for the above link.
3. Firefox fails to navigate to the required page.
Actual Results:  
Firefox couldn't find the page the link pointed to.

Expected Results:  
Firefox should navigate to and display the page pointed to by the URL.
I've hit this too and meant to file a bug a while ago. Still hitting on 3.6 nightlies.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b1pre) Gecko/20090922 Namoroka/3.6b1pre ID:20090922041132
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

9 years ago
Looks like this got fixed with bug 530064, as it now works for me (and the patch is in the right area).

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 530064
You need to log in before you can comment on or make changes to this bug.