Closed Bug 518232 Opened 12 years ago Closed 12 years ago

Socorro UI - displays and reports needed for extensions

Categories

(Socorro :: General, task)

x86
Linux
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lars, Unassigned)

References

Details

Attachments

(1 file)

12 years ago
4.20 KB, text/plain
Details
As of Friday, September 18, 2009, Socorro is saving extension information in the database for each crash.  

There is no UI to retrieve or look at this information in any way.  We need to work it into the user interface.

Those folks with opinions on details, enumerate those opinions here.
the quickest and most needed report might be to help us get a handle on Flash crashes and help the adobe folks to spot regressions in new versions of flash quickly.  I'm thinking that this would allow us to verify the distribution of any .dll in the module list for any particular signature or set of signatures.

Here is a query and report that might do that.

--query form--

product                         [Firefox              ]
version                         [ all                 ]
signature           [matches]   [ NPSWF32.dll@0x77bd0 ]
module/version to look for      [ NPSWF32.dll         ]
in crash reports within the last[ week ]

--report--

7059 crashes at NPSWF32.dll@0x77bd0 in the last week
     NPSWF32.dll  	10.0.32.18  100%

------------------------------------------------------------

or another example

--------------------------------------------------------------

product                          [Firefox              ]
version                          [ all                 ]
signature           [begins with][ NPSWF32.dll         ]
module/version to look for       [ NPSWF32.dll         ]
in crash reports within the last [ day ]

--report--


1059 crashes in NPSWF32.dll@0x77bd0 in the last day
    NPSWF32.dll  	10.0.32.18   100%

658 crashes in NPSWF32.dll@0x889af in the last day
    NPSWF32.dll  	10.0.12.36   100%%

551 crashes in NPSWF32.dll@0xbc897 in the last day
    NPSWF32.dll  	10.0.32.18   42%
    NPSWF32.dll  	10.0.12.36   20%
    NPSWF32.dll  	9.0.15       15%
    ...other top 10 versions of flash that show this crash

465 NPSWF32.dll@0x4e92a
        ...other top 10 versions of flash that show this crash

331 NPSWF32.dll@0x77540
         ...other top 10 versions of flash that show this crash

326 NPSWF32.dll@0x1392a6
          ...other top 10 versions of flash that show this crash

same for all the other flash signatures...

 301 NPSWF32.dll@0xbbff7
 270 NPSWF32.dll@0x1e7e54
 264 NPSWF32.dll@0x4e92c
 251 NPSWF32.dll@0xa10ff
 236 NPSWF32.dll@0x2b72a
 234 NPSWF32.dll@0xe6270
 229 NPSWF32.dll@0xa8654
 229 NPSWF32.dll@0x7c6a3
 227 NPSWF32.dll@0x2005bd
 217 NPSWF32.dll@0x144dae
 210 NPSWF32.dll@0xd08dc
 209 NPSWF32.dll@0x4daa7
 200 NPSWF32.dll@0x255b
 189 NPSWF32.dll@0x13c4f3
 188 NPSWF32.dll@0x7c043
 186 NPSWF32.dll@0x2e81ff
 185 NPSWF32.dll@0x3d7ad
 185 NPSWF32.dll@0x1e7e52
 183 NPSWF32.dll@0x2e5b9a
 183 NPSWF32.dll@0x1d3756
 159 NPSWF32.dll@0x1a953a
cliss is a top flash bug killer active in bugzilla.  he may have additional ideas on what  module version info would be valuable to him.
I'm mostly interested in learning which extensions are correlated with each crash.  For example, if it could say "90% of users who hit this crash had AdBlock Plus installed, compared to 5% of users hitting crashes in general", that would suggest that having AdBlock Plus increases the likelihood of hitting the crash.

Cww has been experimenting with something similar for modules (rather than extensions) as a client-side perl script.

The metrics guys probably know how to pick out correlations effectively and efficiently, and even how to present them.
Depends on: 412605
Ken - let's work on this together and come up with a design then add it to our roadmap for implementation.
there are two paths for analysis and questions to be answered when looking an the modules data.

The first is to help answer the question "for this stack signature (or set of stack signatures), tell me the versions of a specific .dll that I think might be involved in the crash.

that's the request in comment 1.

The second is "for all crashes, tell me about .dll's that have a high probability of being related to any particular crash"

that's more like jesse's request in comment 3 except the modules list doesn't include addons.  we need to gather addon info in crash reports to do that.  I think there is another bug on file to do that.  This is a worthwhile area of analysis, but I think this is also a bit harder problem considering the volume of data, and the number of modules involved.  

I'd urge us to do something simple like comment 1,  that might be quicker, and that a lot of people can use; then continue to work on bigger plans for analyzing all the module data as we go.
(In reply to comment #5)
> that's more like jesse's request in comment 3 except the modules list doesn't
> include addons.  we need to gather addon info in crash reports to do that.  I
> think there is another bug on file to do that.  This is a worthwhile area of
> analysis, but I think this is also a bit harder problem considering the volume
> of data, and the number of modules involved.  

As per comment #0, we've been saving add-ons data since September 18th. The bug you're thinking of is bug 412605.
chofmann: what you're asking for is unrelated to this bug. This bug is about the list of installed extensions, not anything to do with plugins or loaded binary modules.
re comment 9:

right, but the analysis techniques are quite similar I think.  if we add a tab that shows the "addon list" just like we show the "module list" for every crash report, and we have some tools that allow "bottom up" analysis that's a good way to start.  we could actually just tack on the extension list to the bottom of the module list for every crash report, and stuff like cww's tool would just just work for some types of analysis.

the "top down" analysis that examines all crashes that have addons installed is interesting and valuable, but harder.  lets get something quick and dirty going first.
This would be a great start Chris.  I would only be able to add to Jesse's comment right now.  Sometimes it can give us clues if we know what other plugin's or software might be runnning.
Of course not to say having URL data of some sort would be helpful in most cases.
We're now listing all of the add-on extensions installed for each crash, which is available in the Extensions tab.

Choffman: Do the correlation reports found within the Correlations tab for each crash address the request in Comment #9?
yeah, dbaron's reports and integration of that data into the correlations tab of each report is working great!

the other half of the suggestion in a few of comments above still needs some better tools.  for this we need to look at a particular version of a pluggin or addon and find out what signatures it is most strongly associated with.  there are a few bugs open that will help us to start to tackle that problem.

first would be getting flash versions in the .csv files so we can start to examine and play with that data.

this bug could be closed, or become a meta bug for the both kinds of improvements.
Thanks choffman! Let's call this particular bug resolved.

If you could, please open a new ticket for each of the individual requests listed above that still require attention.  Thanks!
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.