make --enable-jemalloc do what it says when building the standalone shell

RESOLVED DUPLICATE of bug 580409

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 580409
9 years ago
7 years ago

People

(Reporter: luke, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
At the moment, building the standalone shell, even with --enable-jemalloc, does not use jemalloc.  Vlad and others have given me kind tips on how this can be done, but ideally, this using jemalloc shouldn't be reserved for special cases, but for normal performance hunting.  The reason is that, assuming jemalloc is faster than glibc/msvc malloc, doing all our development measurements without jemalloc will give us a skewed perspective on the effects of the changes we are making.

I would propose to use jemalloc for ordinary builds (without any flags), but I suspect that might mess up our embedders?
(Reporter)

Updated

9 years ago
Summary: make --enable-jemalloc do what it says in the standalone shell → make --enable-jemalloc do what it says when building the standalone shell

Updated

8 years ago
Blocks: 580409

Updated

8 years ago
Blocks: 586962
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 580409
You need to log in before you can comment on or make changes to this bug.