Install breaks off half way on Windows Mobile 6.5 build 23047

RESOLVED FIXED

Status

Firefox for Android Graveyard
General
--
critical
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Geert Steyaert, Unassigned)

Tracking

Trunk
ARM
Windows Mobile 6 Professional

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Fennec 1.0a3

I tried to install Fennec 1.0a3 on my WM 6.5 23047 build, on a HTC Touch 2 (Elfin). During install, while decompressing and writing the files, in both Internal Memory and also to Sorage Card, the Istallation breaks of, saying it can't be installed. It leaves plenty of files from Fennec in place on the filesystem, in the proper places. But it never gets to the end of the installation successfully.

Both internal memory (80+ MB free) and Storage Card (450+ MB free) should be big enough to receive the files.

The previous version of Fennec, 1.0a2 installs fine on this device, both Internally and on Storage Card.

Reproducible: Always

Steps to Reproduce:
1.just try to install on same(or very similar) WM version, doesn't matter where to : Memory or Storage card

Actual Results:  
half installed and unusable Fennec install.

Expected Results:  
installed fine ....

Updated

9 years ago
tracking-fennec: --- → 1.0a4-wm+
Status: UNCONFIRMED → NEW
Ever confirmed: true
we don't use the cab installer anymore, I'm going to mark this as invalid since we don't use this code anymore.  Please reopen if you still see it with the 7z exe installer
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
Hi, as I'm following also the (pre) alpha and other versions of the desktop Firefox, I found also a file this week on your servers called firefox-3.7a1pre.en-US.wince.cab, same directory as all the other versions of this build. Of course I tried it, now on a 23088 version of WM 6.5 and ...
Somehow different behaviour, it installs and leaves an 'Minefield' icon in the app list but when trying to execute it, it gives a message like this "The file 'firefox' cannot be opened. Either it is not signed with a trusted certificate, or one of it's components cannot be found. If the problem persists, try reinstalling or restoring this file".

If you're suing now an EXE installer instead of a CAB one, why do we still have upstream a CAB file ? Or did I use the wring file all together ?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
the cab file you found is for Windows CE netbooks and not for Windows Mobile.

you want this file: http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/fennec-1.0a4pre.en-US.wince-arm.exe
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
Geert, please comment if this resolves the problem you're having. Once that occurs, I'll switch this to verified.
(Reporter)

Comment 5

8 years ago
I would say the original issue of not installing is fixed now. 
Thanks for that.

Pity the browser is not really usable yet at work as the Wifi accesspoint does some heavy javascript password entering/session logon/logoff tracking and I can't get it to work properly on anything but a Webkit based browser, latest free version of Iris.
But I guess it's still early in the game to to really judge the browser. I'll certainly try it out in lots of different situations.

Thanks for the effort so far, hoping for more goodies to come.
Resolution: INVALID → FIXED

Updated

8 years ago
Component: Windows Mobile → General
OS: Other → Windows Mobile 6 Professional
QA Contact: mobile-windows → general
Hardware: Other → ARM
You need to log in before you can comment on or make changes to this bug.