[mozmill] Opening the Downloads dialog

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
This Mozmill test will cover the following Litmus tests:

https://litmus.mozilla.org/show_test.cgi?id=5936
https://litmus.mozilla.org/show_test.cgi?id=7979
(Assignee)

Comment 1

9 years ago
Created attachment 402376 [details] [diff] [review]
Patch v1

Test with a new shared module called DownloadsAPI which we can extend in the near future.
Attachment #402376 - Flags: review?(adesai)
Er, why?  I think all of this is covered by automated tests run by tinderbox.  Additionally, it looks like your test doesn't listen for windows properly (you can register for a window open topic).

# Ctrl+J on Windows, Cmd+J on Mac or Ctrl+Shift+Y on Linux.
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/downloads/test/browser/browser_bug414214.js#92

For that matter, bug 436552 has a patch that is essentially completed that automates the rest of the test bits.  Your efforts would be better spent finishing the work in that bug and disabling the litmus test.

In general, there a number of "automate litmus test X" in the downloads component that have mostly finished patches.  Please look at them first.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 436552

Updated

9 years ago
Attachment #402376 - Flags: review?(adesai)
(Assignee)

Comment 3

9 years ago
Shawn, for now we will create Mozmill tests even they are already automated or not. We haven't got to the point where we decide if the automated test is enough. Until those tests are not run on localized builds we will further see a litmus test. The Mozmill suite is new and we need as much as possible tests. We already had a couple of tests which have been caused a side-effect which wasn't covered by any automated test.

(In reply to comment #2)
> Additionally, it looks like your test doesn't listen for windows properly (you
> can register for a window open topic).

That is something we will do next quarter.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

9 years ago
Attachment #402376 - Flags: review?(adesai)
(Assignee)

Updated

9 years ago
Status: REOPENED → ASSIGNED
Hey, if you want to duplicate efforts, it's your resources, not mine...
(Assignee)

Comment 5

9 years ago
(In reply to comment #1)
> Created an attachment (id=402376) [details]
> Patch v1
> 
> Test with a new shared module called DownloadsAPI which we can extend in the
> near future.

Aakash, before you ask at the moment we cannot get the localized commandKeys because they are located inside a DTD. I will have to update the code once bug 504635 is fixed.
Depends on: 504635
Comment on attachment 402376 [details] [diff] [review]
Patch v1

This works for me and passes on osx and xp. I'd like to mention that we should start looking into writing documentation about the various functions within the shared-modules somehow. This is nothing that needs to be implemented now, but something that we should think about in the same lines as what Chris Blizzard is doing with dev-docs.
Attachment #402376 - Flags: review?(adesai) → review+
How do we decide to write mozmill tests, if not "we need additional automated coverage for this code path or user activity"?  I can understand missing the existing tests sometimes when scanning them before embarking on a mozmilling project, but to continue duplicating the tests -- thereby doubling the maintenance effort for them when the DLM changes -- once the duplication has been pointed out seems odd.

Needing mozmill tests is fine, I suppose, but we should be writing ones we don't have, not rewriting ones we have just to add to the mozmill corpus, no?  Apologies if I'm missing something here, though!
(Assignee)

Comment 8

9 years ago
Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/8c711c72cc4a
http://hg.mozilla.org/qa/mozmill-tests/rev/b66a6bd04479

(In reply to comment #6)
> (From update of attachment 402376 [details] [diff] [review])
> This works for me and passes on osx and xp. I'd like to mention that we should
> start looking into writing documentation about the various functions within the
> shared-modules somehow. This is nothing that needs to be implemented now, but

As said lately its on my list for the next month.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

9 years ago
(In reply to comment #7)
> How do we decide to write mozmill tests, if not "we need additional automated
> coverage for this code path or user activity"?  I can understand missing the
> existing tests sometimes when scanning them before embarking on a mozmilling
> project, but to continue duplicating the tests -- thereby doubling the
> maintenance effort for them when the DLM changes -- once the duplication has
> been pointed out seems odd.

Such a discussion should be better of in the newsgroups. But to give a short answer in-front... We haven't checked yet, in which areas automated tests are already existent. But that's not the problem. Having users tested those highly used code paths would be even better. Such a test is short and simple to do.

But the main point why we need those is that it help us drastically for localized versions. We don't run any automated test for localized builds. And what I have heard it will not be changed in the near future. Given that localizers would have to run Litmus tests to verify that their version is running. Removing those Litmus tests would be a step backwards because we could miss major points in testing. A really good example was the XML parsing error for the software update dialog for mk and sr for Firefox 3.5. If we would have a test which covers this dialog we would have found it.

I will have a talk at MozCamp next week and will promote Mozmill as testing tool. This framework can be set up by nearly everyone in some simple steps. Running those tests is easy too. So we will hopefully will get much more attention and people running those tests on localized nightly builds mainly days and/or weeks before a major release.

> Needing mozmill tests is fine, I suppose, but we should be writing ones we
> don't have, not rewriting ones we have just to add to the mozmill corpus, no? 
> Apologies if I'm missing something here, though!

I hope my above answer is more concrete this time. I will have a blog post once I have been returned from the conference. Seems like we should more clarify our target.
Duplicate of this bug: 524839
(Assignee)

Updated

9 years ago
No longer depends on: 504635
(Assignee)

Updated

9 years ago
Depends on: 559836
(Assignee)

Updated

8 years ago
Component: Download Manager → Mozmill Tests
Product: Toolkit → Testing
QA Contact: download.manager → mozmilltests
(Assignee)

Comment 11

8 years ago
Move of Mozmill Test related project bugs to newly created components. You can
filter out those emails by using "Mozmill-Tests-to-MozillaQA" as criteria.
Component: Mozmill Tests → Mozmill Tests
Product: Testing → Mozilla QA
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.