n900: selecting a character from symbol map clears awesome bar

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
--
critical
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: aakashd, Assigned: blassey)

Tracking

({qablocker})

Trunk
ARM
Maemo
qablocker

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Build Id:

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20090923
Fennec/1.0b4pre

Steps to Reproduce:
1. Go to the url bar and try to type in http://people.mozilla.org/~mfinkle/size-content.html

Actual Results:
When you select the "~" in the symbol map, fennec will clear the awesome bar and go back to the browser

Expected Results:
The tilde should show up and the cursor should still be blinking in the url bar.
(Reporter)

Updated

9 years ago
tracking-fennec: --- → ?

Updated

9 years ago
tracking-fennec: ? → 1.0+
The popup symbol list also doesn't work for fields embedded in web pages.  It gets dismissed, but no character is inserted into the field.
n810 "Chr" popup doesn't cause this bug; I suspect its due to focus.  On the n900, the awesome bar remains on screen while the symbols are displayed, its only on return from the dialog that it's dismissed.
Another observation: clicking outside symbol dialog to dismiss also causes aweseome bar dismissal.
I didn't get far into what else could be happening while debugging this, someone should look at this before I return on Nov 6th.

Updated

9 years ago
Keywords: qablocker
Created attachment 410582 [details] [diff] [review]
patch
Assignee: nobody → bugmail
Attachment #410582 - Flags: review?(mark.finkle)
Comment on attachment 410582 [details] [diff] [review]
patch

Let's remove handleEvent entirely

>diff --git a/chrome/content/bindings.xml b/chrome/content/bindings.xml
>     <implementation implements="nsIAutoCompletePopup, nsIDOMEventListener">

Remove nsIDOMEventListener

>       <constructor><![CDATA[
>-        window.addEventListener("blur", this, true);
>       ]]></constructor>

Remove <constructor> since we don't use it

>-      <!-- Handles blur events on the window while the popup is open. -->
>       <method name="handleEvent">

>       </method>

Let's remove handleEvent altogether since we no longer use it
Attachment #410582 - Flags: review?(mark.finkle) → review-
Created attachment 410607 [details] [diff] [review]
patch v.2, remove everything
Attachment #410582 - Attachment is obsolete: true
Attachment #410607 - Flags: review?
(Assignee)

Updated

9 years ago
Attachment #410607 - Flags: review? → review?(mark.finkle)
Comment on attachment 410607 [details] [diff] [review]
patch v.2, remove everything

>     <implementation implements="nsIAutoCompletePopup, nsIDOMEventListener">

Remove "nsIDOMEventListener" too
Attachment #410607 - Flags: review?(mark.finkle) → review+
pushed http://hg.mozilla.org/mobile-browser/rev/061d3ab4cc54
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
The bug is not fixed yet. The patch keeps the awesomebar from being dismissed, but no symbols are inserted into the urlbar
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Leaving this bug as fixed - the awesomebar is not cleared anymore. Filing a new bug for the symbol editor not working.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
The awesomebar isn't dismissed anymore, as noted, but, yeah, you can't enter a tilde into the field. 

What is the new bug number for that?
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
You need to log in before you can comment on or make changes to this bug.