Right click on bookmark crashes firefox [@ strcmp - nsClipboard::HasDataMatchingFlavors]

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: Steve Schveighoffer, Unassigned)

Tracking

({crash})

3.5 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090909 Fedora/3.5.3-1.fc11 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090909 Fedora/3.5.3-1.fc11 Firefox/3.5.3

If I right click a bookmark in the bookmark toolbar to try and delete it, firefox crashes.  If I try to right click a bookmark in the bookmarks menu, it crashes.  If I open "organize bookmarks", then click on "bookmark toolbar" or "bookmark menu", it crashes.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox
2. Right click "Most Visited" or other bookmark toolbar item
3. Firefox crashes
Actual Results:  
Firefox Crash

Expected Results:  
popup menu to tell what to do with bookmark.
Can you get a stacktrace? It is easiest to get a mozilla.com build for linux, but you can use https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report as well
Component: Menus → Bookmarks & History
QA Contact: menus → bookmarks
Version: unspecified → 3.5 Branch

Updated

8 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 2

8 years ago
Created attachment 402621 [details]
trace of error occurring

attached trace
(Reporter)

Updated

8 years ago
Attachment #402621 - Attachment mime type: application/octet-stream → text/plain
I think this is bug 495392.
Whiteboard: DUPEME
Does it happen with a clean profile?
(Reporter)

Comment 5

8 years ago
Yes, in fact I created a new profile to create the stack trace and report the bug so I could leave open my normal profile's firefox to read instructions (on how to get a stacktrace) and report the bug.
it is possible comment 3 is correct, the stack trace seems to point there, but i'm just adding a dependancy for now.
Depends on: 495392

Comment 7

8 years ago
#4  strcmp () at ../sysdeps/i386/i686/strcmp.S:39
No locals.
#5  0x0583fb97 in nsClipboard::HasDataMatchingFlavors (this=0xaff10160, 
    aFlavorList=0xaff0c6f0, aLength=3, aWhichClipboard=1, _retval=0xbfc87a18)
    at nsClipboard.cpp:448
        atom_name = 0x0
Summary: Right click on bookmark crashes firefox → Right click on bookmark crashes firefox [@ strcmp - nsClipboard::HasDataMatchingFlavors]
(Reporter)

Comment 8

8 years ago
Fedora updated it's version to 3.5.4, and this bug no longer occurs.  Not sure if it's something that was fixed on purpose.  Might want to try the related bug to see if it's also fixed.  Has anyone else had this crash occur?  Can they confirm that 3.5.4 fixes/does not fix the problem?
(Reporter)

Comment 9

8 years ago
It was suggested that since I was the only one who has seen this, and since it has been resolved in my case, that I should close it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ strcmp - nsClipboard::HasDataMatchingFlavors]

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.