Closed Bug 518595 Opened 11 years ago Closed 10 years ago

[HTML5] Images boxes overlaid with text - no image shown

Categories

(Core :: DOM: HTML Parser, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jmjjeffery, Unassigned)

References

()

Details

(Keywords: regression)

Visit the URL, scroll to bottom, should be 5 images related to the search. 
I see this instead:
http://img59.imageshack.us/i/googleimg.png/

Good in cset: http://hg.mozilla.org/mozilla-central/rev/80dc1c31b175
Bad in cset:  http://hg.mozilla.org/mozilla-central/rev/7bfe69ba4bc9
This regressed with cset: 
http://hg.mozilla.org/mozilla-central/rev/f6df32312266

bug: https://bugzilla.mozilla.org/show_bug.cgi?id=515142
Summary: Images boxes overlaid with text - no image shown → [HTML5] Images boxes overlaid with text - no image shown
Blocks: 515412
Blocks: 515142
No longer blocks: 515412
Component: Layout: Images → HTML: Parser
QA Contact: layout.images → parser
I'm kind of new at this (one other bug).. but here it goes.
For complete HTML links please see my nightly post: http://forums.mozillazine.org/viewtopic.php?f=23&t=1508285&start=23, thanks.

It looks like it might/could be a google search bug... With "html5.enable;true" it has worked for me, until I did search #4 below...
Different Google search methods (see below) send different parameters to google search (+possible cookies used by search).

FWIW:

      I noticed, when I clicked the URL mentioned in the bug #518595:
      The URL: http://www.google.com/#hl=en&q=mars&fp=1&cad=b
      was converted into this URL: http://www.google.com/search?hl=en&q=mars&cad=b&cad=h which WFM (shows the 5 images correctly)...
      Looking closer at the URL in the bug I noticed that the parameters (after "#" in bug's URL; and "?" in my) and the URL's were also different: http://www.google.com/ vs. http://www.google.com/search.


So I tried the following Google "mars" searches, to see if one way worked and others didn't:

      1) From the Firefox search bar I get: http://www.google.com/search?q=mars&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a, which works with html5.enable=true/false.
      2) When I did the search from iGoogle my home page, I get: http://www.google.com/search?...q=mars...aq=f..., which works, html5=true/false.
      3) With html5=false, If I search for "mars" using Google (classic home), the URL I get is: http://www.google.com/#hl=en&source=hp&fkt=4271&fsdt=25396&q=mars&btnG=Google+Search&aq=f&aqi=g10&oq=mars&fp=, which works (even if I toggle html5 on/off and reload the page).
      4) With html5=true, when I searched for "mars" using Google, the URL I get is: http://www.google.com/#hl=en&source=hp&fkt=&fsdt=344648&q=mars&btnG=Google+Search&fp=, it did not work (http: text addresses are display inside the boxes where the pictures are supposed to be)... then when toggled html5=off/on and reloaded the page, the pictures appear/disappear constantly... then after awhile it started working, and I can't get it to fail again (cookies/cache? I tried clearing the last for hours)...

Could the inconsistent results be do to HTML5 not being completely finished in Minefield (when it is completely/mostly working wont the default be changed to html5.enable=true)?
Marking this as dependent on bug 524447, because I don't see this with my local patch queue applied. (Not suggesting that the patch for bug 524447 in particular has anything to do with this.) Need to revisit this once I've landed 14 or so patches.
Depends on: 524447
FWIW, After updating to Win7 Home Premium RTM x64, clean intall along with a clean install of Minefield, except for my bookmarks & places.sqlite - I am no seeing this issue anymore with HTML5 enabled. 

Henri, I'll leave this open while you investigate, but I suspect this is going to resolve out WFM.  

Could be, that something was funky with Win7RC perhaps.
Resolving as WFM per comment 4.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.