Tab character not displayed in form <input> elements

RESOLVED DUPLICATE of bug 484155

Status

()

RESOLVED DUPLICATE of bug 484155
9 years ago
9 years ago

People

(Reporter: paul.linden, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_1; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

A bit of background. I'm maintaining a web interface to a database, and some forms display text that we retrieve from this database so operators can modify/check the values. 

We came across an issue with some data in production, but viewing the relevant form showed no problems - however, direct SQL showed that the data were prefixed with the tab character. Naturally, the tabs were incorrectly entered (presumably through some corrupted SQL patch or copy and paste), but we had to log on directly to the db to see this. We try to minimize this as much as possible, hence the web interface.

Viewing the form in Firefox 3.53 on Windows and OS X and 3.0.5 on Linux had the same issue - the tab character wasn't shown. Safari and Opera on both Windows and OS X and IE on Windows show the tab.

We are very much a geeky crowd here at work who almost exclusively use only Firefox, but if we can't rely on Firefox to show exactly what's being retrieved from the db, we are going to have to switch browsers. And in fact, we are recommending our users use IE (blegh) or Safari. 

Considering that you can paste a tab character into a text input field, Firefox really should display exactly what's in the field value.

And no, we can't massage the data to display tabs as e.g. \t - there are several hundred tables with many columns. And with 10s of web forms we can't easily switch to using textboxes.

Reproducible: Always

Steps to Reproduce:
Open the following HTML snippet in Firefox. Compare to other browsers.
<html>
    <body>
        Input <input type="text" value="	Some text"/>
    </body>
</html>
Actual Results:  
We see just [Some text]

Expected Results:  
We should see [	Some text]
(Reporter)

Comment 1

9 years ago
My apologies - this is a duplicate.

I changed my search inputs and came across https://bugzilla.mozilla.org/show_bug.cgi?id=484155
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 484155
You need to log in before you can comment on or make changes to this bug.