Narcissus: get rid of __defineProperty__, replace uses with Object.defineProperty

RESOLVED DUPLICATE of bug 546532

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 546532
9 years ago
8 years ago

People

(Reporter: Waldo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
__defineProperty__ is used to implement non-enumerable properties and such, but Object.defineProperty subsumes its functionality and even supports defining setters and getters.  When Object.defineProperty shows up, we should get rid of __defineProperty__.
Bug 546532 dups this bug but has a patch. Dup'ing forward.

/be
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 546532
You need to log in before you can comment on or make changes to this bug.