bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

SUMO 1.4 - Hitting the Submit button doesn't reload the thread, it returns the user to the first page of the forum

VERIFIED DUPLICATE of bug 518979

Status

support.mozilla.org
Forum
VERIFIED DUPLICATE of bug 518979
9 years ago
9 years ago

People

(Reporter: the-edmeister, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.14) Gecko/2009082707 Firefox/3.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.14) Gecko/2009082707 Firefox/3.0.14 ID:2009082707

Previously when a user hit the Submit button, the new posting would be submitted and that thread would reload that thread with the new submission. Now, as of 09-24-09 with SUMO 1.4, Submit reloads the first page of the forum regardless of which page the user was browsing when they opened a particular thread. That action is the same even when the thread was opened on a new Tab. 
While that might not be a bad feature for unregistered users, to keep them from submitting a posting to the thread they just started (which happens at least a dozen times each day)- it makes doing support here a bit harder. There is also a problem with opening another thread in a Tab when that page is reloading - it seems during the redirect back to the first page of the forum threads.

Reproducible: Always

Actual Results:  
When the re-direct back to the first forum page is happening, I am unable to open any other forum threads in a new tab. It is like the forum software won't allow me more than one simultaneous connection (nope, no about:config mods done to connection prefs).

Expected Results:  
Reloading after a submission shouldn't cause a problem loading another thread in another Tab.

Request for Enhancement for Forum Moderators & Contributors, and maybe Registered Users:
A preference in the User Preferences panel for us to toggle that feature off.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 518979
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.