Closed Bug 519186 Opened 12 years ago Closed 12 years ago

drag & drop in bookmarks menu does not correctly update the view

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 3.7a1
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: mak, Assigned: mak)

References

Details

(Keywords: regression, verified1.9.2)

Attachments

(1 file)

This is most likely regression from bug 498130

1. create a new profile
2. open bookmarks menu
3. drag "Get bookmarks add-ons" below the next separator

result:
4. item moves to a "random" position

expected:
4. correct position for drop
sounds like it is not taking in count the _startMarker
indeed in nodeMoved popup.insertBefore(nodeElt, popup.childNodes[aNewIndex]);
should most likely do the same as nodeInserted
let index = popup._startMarker + 1 + aIndex;
marco: I cannnot test this, but I'll gladly review ;)
yeah, taking.
Assignee: nobody → mak77
Attached patch patch v1.0Splinter Review
Attachment #403484 - Flags: review?(mano)
Duplicate of this bug: 519775
http://hg.mozilla.org/mozilla-central/rev/c2906e26f75a
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
the patch has been merged by Mano in 1.9.2 landing for bug 498130. so this is fixed on that branch too.
Verified fix on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1pre) Gecko/20091009 Namoroka/3.6b1pre 
and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091009 Namoroka/3.7a1pre
Status: RESOLVED → VERIFIED
Keywords: verified1.9.2
Flags: in-testsuite?
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.