Closed Bug 519348 Opened 10 years ago Closed 10 years ago

Blocklist radhslib.dll, an unsupported add-on

Categories

(Toolkit :: Blocklist Policy Requests, defect, P2, critical)

x86
Windows XP
defect

Tracking

()

RESOLVED FIXED
Tracking Status
blocking1.9.2 --- -
status1.9.2 --- .2-fixed

People

(Reporter: cbook, Assigned: johnath)

References

(Depends on 1 open bug)

Details

(Keywords: crash, topcrash, verified1.9.2)

Attachments

(1 file)

From the Topcrash Stats:

http://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A3.5.3&platform=windows&query_search=signature&query_type=exact&query=&date=&range_value=1&range_unit=weeks&do_query=1&signature=radhslib.dll%400x3b6f

radhslib.dll is a part of the Naomi web filter by Radiant Morning Technologies, according to some forums. Will test there.
Flags: blocking-firefox3.6?
Blocking 3.6+ per CrashKill effort.
Flags: blocking-firefox3.6? → blocking-firefox3.6+
Marking all topcrash bugs as P2 (3.6 release blockers, but not 3.6b1 blockers)
Priority: -- → P2
Assigning to Tomcat.
Assignee: nobody → cbook
while running this webfilter, the vm got very slow (also its an since 2006 or so unsupported product anymore), but still no crash so far
If this product is no longer under development and there's clearly not a way for us to get the developers to fix it, we should blocklist the dll. All present at the CrashKill meetings agree.

-> addons.mozilla.org::Blocklisting
Assignee: cbook → nobody
Component: General → Blocklisting
Product: Firefox → addons.mozilla.org
QA Contact: general → blocklisting
Version: 3.5 Branch → unspecified
Summary: Crash [@radhslib.dll@0x3b6f] → Blocklist radhslib.dll, an unsupported add-on
Oh, the unsupported comment is based on http://www.radiance.m6.net/ via Tomcat.
morgamic: Can we get this on the list for the next Blocklist update? Maybe Friday or so? I'm not sure how regularly we do them.
Assignee: nobody → morgamic
IS this installed as addon or as LSP which can not be blocked ?
Blocklist "radhslib.dll" all versions, all apps?
Status: NEW → ASSIGNED
Can this be blocked at the plugin level, or only as a DLL? Tomcat - you ran this in a VM, does that mean there is an associated plugin?  Or does this just drop in the components directory?
Tomcat, can we get an answer to comment 10? We need to know if this can be blocked at the plugin level or not; if not, we need to patch the code to block it at the DLL level.
(In reply to comment #10)
> Can this be blocked at the plugin level, or only as a DLL? Tomcat - you ran
> this in a VM, does that mean there is an associated plugin?  Or does this just
> drop in the components directory?

Retested this and seems its DLL Level - DLL was in  C:\Program Files\rnamfler
 and no plugin listed in Firefox
DLL blocklist candidate - taking.

The crash dumps I'm looking at all report no version for this DLL, so the patch uses the UNVERSIONED macro.
Assignee: morgamic → johnath
Attachment #422268 - Flags: review?(vladimir)
http://hg.mozilla.org/mozilla-central/rev/59ea568ba8a4

(with a terrible checkin comment that didn't include an r=vlad - sorry world.)
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Johnath: Do we want this on the 1.9.2 branch?
(In reply to comment #15)
> Johnath: Do we want this on the 1.9.2 branch?

Unless the crashes have disappeared on their own, I generally think we should take any blocklist addition on branches. They don't introduce code risk, they mitigate topcrashes (by definition!), and nothing about the evaluation process we go through here is branch-specific.

Of course, first we need a way to ask for branch approval...
It's currently the #107 topcrasher
Comment on attachment 422268 [details] [diff] [review]
Blocklist unversioned instances of radhslib.dll

And Dan just installed the flag, so requesting approval
Attachment #422268 - Flags: approval1.9.2.1?
blocking1.9.2: ? → -
Comment on attachment 422268 [details] [diff] [review]
Blocklist unversioned instances of radhslib.dll

a1922=beltzner
Attachment #422268 - Flags: approval1.9.2.2? → approval1.9.2.2+
Duplicate of this bug: 427406
Verified for 1.9.2 by looking at checked in source.
Keywords: verified1.9.2
Depends on: 750601
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.