Closed Bug 519355 Opened 13 years ago Closed 13 years ago

Crash [@ wcslen] involving PR_GetHostByName

Categories

(Core :: Networking, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 508292

People

(Reporter: Dolske, Assigned: Dolske)

Details

(Keywords: topcrash)

Crash Data

Looking at topcrash reports, about 1/3 of the crashes with this signature are bug. The other 2/3 have a stack like: 

0  	msvcrt.dll  	wcslen  	
1 	mswsock.dll 	HostentBlob_WriteNameOrAlias 	
2 	mswsock.dll 	HostentBlob_CreateFromRecords 	
3 	mswsock.dll 	HostentBlob_WriteNameOrAlias 	
4 	mswsock.dll 	Rnr_DoDnsLookup 	
5 	mswsock.dll 	NSPLookupServiceNext 	
6 	ws2_32.dll 	NSPROVIDER::NSPLookupServiceNext 	
7 	ws2_32.dll 	NSPROVIDERSTATE::LookupServiceNext 	
8 	ws2_32.dll 	NSQUERY::LookupServiceNext 	
9 	ws2_32.dll 	WSALookupServiceNextW 	
10 	ws2_32.dll 	WSALookupServiceNextA 	
11 	ws2_32.dll 	getxyDataEnt 	
12 	ws2_32.dll 	gethostbyname 	
13 	nspr4.dll 	PR_GetHostByName 	nsprpub/pr/src/misc/prnetdb.c:722
14 	nspr4.dll 	pr_GetAddrInfoByNameFB 	nsprpub/pr/src/misc/prnetdb.c:1987
15 	nspr4.dll 	PR_GetAddrInfoByName 	nsprpub/pr/src/misc/prnetdb.c:2016
16 	xul.dll 	nsHostResolver::ThreadFunc 	netwerk/dns/src/nsHostResolver.cpp:884
17 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
18 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
19 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/src/threadex.c:348
20 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/src/threadex.c:326
21 	kernel32.dll 	BaseThreadStart
Assignee: nobody → dolske
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 508292
Crash Signature: [@ wcslen]
You need to log in before you can comment on or make changes to this bug.