Closed Bug 519403 Opened 12 years ago Closed 12 years ago

Bug when rendering 2 <span> elements

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 484448

People

(Reporter: 7wmfudht533yphd, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

If you try to render this HTML code :

<span style="font-weight:bold;">carte son</span> <span style="text-decoration:underline;">externe</span>

You will see there is no space between the 2 spans !!

Reproducible: Always

Steps to Reproduce:
1. create an HTML page with the code
2. open it with firefox
Actual Results:  
You see "carte sonexterne"

Expected Results:  
"carte son externe" with a space between "carte son" and "externe"
I see the space in the test URL I added.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
In fact, this is a little bit more complicated.
The problem comes from a CSS bug with the "display:table" property on a parent element.

Try this exemple :

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">
<head>
	<title>test</title>
	<style>
	p {
		display: table;
	}
	span {
		margin:0;
	}
	</style>
</head>
<body>
<p>
	... <span style="font-weight:bold;">a word</span>  <span style="text-decoration:underline;">an other</span> ... where is the space ?
</p>
</body>
</html>

regards
Status: RESOLVED → VERIFIED
The space is there on trunk nightly builds, so the fix will be in future versions of Firefox.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 484448
You need to log in before you can comment on or make changes to this bug.