Default font size and type is too large/bad

VERIFIED WONTFIX

Status

SeaMonkey
Preferences
P3
normal
VERIFIED WONTFIX
18 years ago
13 years ago

People

(Reporter: Karl Ove Hufthammer, Assigned: Frank Tang)

Tracking

Trunk
mozilla0.9.7
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
The default font size in Mozilla in Windows is 16px, which is way to big. It 
should be reduced to 14px.

IE's huge default font size is one reason we can't get people (web designers) 
to specify font size using relative units (ems or %). They say "nobody" change 
the default font size in their browser (or even *know* they can do it), and 
their web pages would look really bad (i.e. not well designed) with such a huge 
font. Several people (site designers) have told me that they won't begin using 
relative units if not the popular browsers start having more sensible default 
font sizes.

I use ems on my site, but am sad to see that it looks rather ugly compared to 
other sites *because* of the font size. 14px is a much more sensible default 
value. Just compare a 16px (=1em) Arial web page with almost any other page. 
16px isn't a sensible default value if all sites which *do* specifiy fonts in 
absolute units use a much smaller font size. (And the menus and dialog boxes in 
Mozilla also uses a mush smaller font size!)

Also, sans-serif fonts are much easier to read on monitors than serif fonts are 
(the opposite is the case on paper). Therefore, 'Sans Serif' should be 
the 'Default Type', *not* Serif.

I don't know how the default font families are selected (mine shows 'Times New 
Roman', 'Arial' and 'Courier New' as 'Serif', 'Sans Serif' and 'Monospace'). If 
they are hard-coded, the default font for 'Monospace' should (on Windows, and 
of course only if it's available) be 'Andale Mono' (included with some versions 
of Win98, Win 2000, IE and Office). This looks much better than Courier New, 
and is specially designed to look good on screen.

Comment 1

18 years ago
Default fonts should be specified in points, not pixels.  Pixels are not
portable to high resolution displays.
No points, please. Portability of points is only theoretical. In practice, the logical 
resolutions are so broken that points cause a lot of trouble.

http://www.pp.clinet.fi/~henris/en/units.html

If the font is too small on a high resolution display, it is more straight-forward and 
understandable to set the pref to a larger pixel value. When setting the pref for on-screen 
display, the px unit the most sense. Of course different people will want to set the pref to a 
different pixel value. That's why it is a pref.

Comment 3

18 years ago
Confirming. The overly large default font size threatens to make a mockery of
its intended use as a `medium' size.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Default font size and type to large/bad → Default font size and type is too large/bad
(Reporter)

Comment 4

18 years ago
Created attachment 20250 [details]
Screenshot showing http://home.no.net/huftis/ in Mozilla with default font size.
(Reporter)

Comment 5

18 years ago
Created attachment 20251 [details]
Screenshot showing http://home.no.net/huftis/ in Opera 5 with default font size.
(Reporter)

Comment 6

18 years ago
Adding mozilla1.0 keyword.
Keywords: mozilla1.0

Comment 7

17 years ago
If there is proper determination of screen dpi, then either point size or pixel
sizing will work.  

The problem isn't that one or the other doesn't make sense, it is that dpi isn't
a reliable, known factor on most platforms.  Recent "fixes" include versions of
IE on the Mac let the user choose her screen dpi. Of course, on X11 systems
screen dpi can be properly set as part of the X install, but next to no one
knows/does this.  

It seems to me the only proper determination of default font size is exactly
what the *system* default font size is.  If the user chooses to use the system
definition for 12pt (or 6 or 72, for that matter) as the default font size, then
such should be the default size of the "medium" setting in the browser.  

Pixel-based sizes can only be computed wrt the system dpi setting, which is
likely to be incorrect for the forseeable future.  Providing the user a means to
set their dpi for Mozilla seems to be the right way to go to solve this
particular problem.

Point-based sizes only really mean something on paper publications, at least
until such time as we regain Postscript (or similar) rendering on digital
displays.  Therefore, point-based sizing should equate to system definitions of
such.
(Reporter)

Comment 8

17 years ago
> It seems to me the only proper determination of default font
> size is exactly what the *system* default font size is.  If
> the user chooses to use the system
> definition for 12pt (or 6 or 72, for that matter) as the
> default font size, then
> such should be the default size of the "medium" setting in the browser.

For Windows, this would be the font size used for 'Dialog' (which also is used
in various places in the Classic and Modern theme).

Adding mpt to CC list as I think he'll be interested in this bug (based on his
earlier comment).
->mcafee
Assignee: matt → mcafee

Comment 10

17 years ago
This could be related to bug 5599 "Need a dialog with a nice ruler to set the 
screen resolution".  There is bug 69205 too.

Comment 11

17 years ago
The debate about the default font families should be moved over to bug 61883.  I 
did not check in the patch yet; you can make suggestions about which fonts should 
be used on Windows and Unix.

Here is what I have on Windows: 
  serif:       "Times New Roman, Times"
  sans-serif:  "Arial, Verdana"
  monospace:   "Courier New, Courier, Andale Mono"
  cursive:     "Lucida Handwriting, Zapf Chancery, Chancery, Comic Sans MS"
  fantasy:     "Matisse ITC, Comic Sans MS"

Don't forget to comment on bug 61883.  The current bug should be left for 
problems with font sizes.

Comment 12

17 years ago
*** Bug 76074 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
over to pierre
Assignee: mcafee → pierre

Updated

17 years ago
Keywords: intl, nsBranch

Updated

17 years ago
Keywords: topembed

Comment 14

17 years ago
reassigned to rbs, like bug 61883 and bug 30910
Assignee: pierre → rbs

Comment 15

17 years ago
Not sure what to do with this bug. Being a 'topembed', this bug needs to be
dealt with pretty soon. The current default values, 16px for the variable-width
font and 13px for the fixed-width font, have been purposely choosen so as to
match earlier values from Nav4.x

>Additional Comments From Huftis
>For Windows, this would be the font size used for 'Dialog' (which also is used
>in various places in the Classic and Modern theme)."

BTW, this is an interesting suggestion, but it will break continuity with Nav4.x
and will affect the many pages that use <font size="-1"> on the _whole_ page
because they have come to rely on the fact that the default size is 16px.

Comment 16

17 years ago
I did a little experiment and tried getting the default size from either of the
CSS fonts ('Dialog', 'Document', ...). The default size returned by the system
is too small, and that caused Mozilla to render web pages too small.

Should resolve as wontfix?

Re-assigning back to pierre as this is a hot potato.
Assignee: rbs → pierre
I would suggest this is a WONTFIX, yeah. We're doing the same as IE on Windows,
and really we probably can't afford to change that.

roberts: Why is this topembed? (Feel free to mail me directly ian@hixie.ch if
the reasons are Netscape Confidential.)

Comment 18

17 years ago
rbs: sorry, I overlooked the topembed nomination before I reasigned this to you.

This bug could have been closed as dup of bug 61883 but I did not do so in order 
to cover problems with font sizes that may arise if some of the default fonts are 
not installed.  For instance, if monospace is defined as "Courier New, Courier, 
Andale Mono" and none of the Courier fonts is installed, Andale may look too big 
or too small.  I imagine the issue will be addressed by rbs and his work on font-
size-adjust.  That's why I reassigned the bug to him in order to make the call: 
leave it open just in case, or close it because the entire issue will be moot.

Either way, I don't understand why Cindy Roberts marked it topembed.  If 
something related to font sizes is so important that it deserves to be topembed, 
it probably should be part of a separate, more specific, bug report.

Comment 19

17 years ago
Putting off the topembed list and reassigning back to rbs, based on my comments 
above.  Kat Momoi is going to open a separate bug report for problems with 
Japanese fonts that triggered putting this bug on the topembed list.
Assignee: pierre → rbs
Keywords: intl, nsBranch, topembed
(Assignee)

Comment 20

17 years ago
BTW, if anyone want to change the default size in the source code. Here is the 
place you need to change it
for window:
modules/libpref/src/win/winpref.js
106 pref("font.size.variable.ar", 16);
107 pref("font.size.fixed.ar", 13);
108 
109 pref("font.size.variable.el", 16);
110 pref("font.size.fixed.el", 13);
111 
112 pref("font.size.variable.he", 16);
113 pref("font.size.fixed.he", 13);
114 
115 pref("font.size.variable.ja", 16);
116 pref("font.size.fixed.ja", 16);
117 
118 pref("font.size.variable.ko", 16);
119 pref("font.size.fixed.ko", 16);
120 
121 pref("font.size.variable.th", 16);
122 pref("font.size.fixed.th", 13);
123 
124 pref("font.size.variable.tr", 16);
125 pref("font.size.fixed.tr", 13);
126 
127 pref("font.size.variable.x-baltic", 16);
128 pref("font.size.fixed.x-baltic", 13);
129 
130 pref("font.size.variable.x-central-euro", 16);
131 pref("font.size.fixed.x-central-euro", 13);
132 
133 pref("font.size.variable.x-cyrillic", 16);
134 pref("font.size.fixed.x-cyrillic", 13);
135 
136 pref("font.size.variable.x-unicode", 16);
137 pref("font.size.fixed.x-unicode", 13);
138 
139 pref("font.size.variable.x-western", 16);
140 pref("font.size.fixed.x-western", 13);
141 
142 pref("font.size.variable.zh-CN", 16);
143 pref("font.size.fixed.zh-CN", 16);
144 
145 pref("font.size.variable.zh-TW", 16);
146 pref("font.size.fixed.zh-TW", 16);

For Mac:
modules/libpref/src/mac/macprefs.js

125 pref("font.size.variable.ar", 16);
126 pref("font.size.fixed.ar", 13);
127 
128 pref("font.size.variable.el", 16);
129 pref("font.size.fixed.el", 13);
130 
131 pref("font.size.variable.he", 16);
132 pref("font.size.fixed.he", 13);
133 
134 pref("font.size.variable.ja", 14);
135 pref("font.size.fixed.ja", 14);
136 
137 pref("font.size.variable.ko", 16);
138 pref("font.size.fixed.ko", 16);
139 
140 pref("font.size.variable.th", 16);
141 pref("font.size.fixed.th", 13);
142 
143 pref("font.size.variable.tr", 16);
144 pref("font.size.fixed.tr", 13);
145 
146 pref("font.size.variable.x-baltic", 16);
147 pref("font.size.fixed.x-baltic", 13);
148 
149 pref("font.size.variable.x-central-euro", 16);
150 pref("font.size.fixed.x-central-euro", 13);
151 
152 pref("font.size.variable.x-cyrillic", 16);
153 pref("font.size.fixed.x-cyrillic", 13);
154 
155 pref("font.size.variable.x-unicode", 16);
156 pref("font.size.fixed.x-unicode", 13);
157 
158 pref("font.size.variable.x-western", 16);
159 pref("font.size.fixed.x-western", 13);
160 
161 pref("font.size.variable.zh-CN", 16);
162 pref("font.size.fixed.zh-CN", 16);
163 
164 pref("font.size.variable.zh-TW", 16);
165 pref("font.size.fixed.zh-TW", 16);

For Unix:
modules/libpref/src/unix/unix.js

152 pref("font.size.variable.ar", 16);
153 pref("font.size.fixed.ar", 12);
154 
155 pref("font.size.variable.el", 16);
156 pref("font.size.fixed.el", 12);
157 
158 pref("font.size.variable.he", 16);
159 pref("font.size.fixed.he", 12);
160 
161 pref("font.size.variable.ja", 16);
162 pref("font.size.fixed.ja", 16);
163 
164 pref("font.size.variable.ko", 16);
165 pref("font.size.fixed.ko", 16);
166 
167 pref("font.size.variable.th", 16);
168 pref("font.size.fixed.th", 12);
169 
170 pref("font.size.variable.tr", 16);
171 pref("font.size.fixed.tr", 12);
172 
173 pref("font.size.variable.x-baltic", 16);
174 pref("font.size.fixed.x-baltic", 12);
175 
176 pref("font.size.variable.x-central-euro", 16);
177 pref("font.size.fixed.x-central-euro", 12);
178 
179 pref("font.size.variable.x-cyrillic", 16);
180 pref("font.size.fixed.x-cyrillic", 12);
181 
182 pref("font.size.variable.x-unicode", 16);
183 pref("font.size.fixed.x-unicode", 12);
184 
185 pref("font.size.variable.x-western", 16);
186 pref("font.size.fixed.x-western", 12);
187 
188 pref("font.size.variable.zh-CN", 16);
189 pref("font.size.fixed.zh-CN", 16);
190 
191 pref("font.size.variable.zh-TW", 16);
192 pref("font.size.fixed.zh-TW", 16);

Notice that the control is depend on platform and language group. 

Notice on Mac we alreadyd change the Japanese default size to 14 for the quality 
of font's issue. and on Unix some of them are 16 

Please don't make any change in the cvs untill we got proper decision. Make any 
chnages in Window are agreed by rbs and me, changes to Mac agreed by me and 
changes to unix agreed by bstell and rbs. 

Thanks




Comment 21

17 years ago
nav triage team:

rbs, can ftang take over this bug?

Comment 22

17 years ago
Sure -- re-assigning to ftang.
Assignee: rbs → ftang

Updated

17 years ago
Blocks: 79151
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Updated

17 years ago
Target Milestone: --- → mozilla0.9.4

Updated

17 years ago
Keywords: nsbranch+
(Assignee)

Comment 23

17 years ago
so... it seems all the suggestion in this bug report are purly personal
suggestion and Opera5 compatable (vs IE / N4 compatble) issue. No CSS or
whatever standard are related to this bug, right ?
remove nsbranch+ and move to m0.9.5
Keywords: nsbranch+ → nsbranch
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Comment 24

17 years ago
move to moz 0.9.7
Target Milestone: mozilla0.9.5 → mozilla0.9.7
(Assignee)

Comment 25

17 years ago
mark it won't fix unless there are a clear reason that we want to change it to
make it uncompatable with n4 n6 n6.1 and IE
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
VERIFIED per my comments above.
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: nsbranch → nsbranch-
*** Bug 99770 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.