Downloaded files bigger than 4GB are truncated

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: olivier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2

When I tried to download the OpenSuSE ISO image (which weighs 4,3GB), SeaMonkey under Windows downloaded only 251MB. Note: this happened also with IE7 under Windows.

Reproducible: Always

Steps to Reproduce:
1. Open http://software.opensuse.org/
2. Select DVD, http or ftp download
3. Click "Installation DVD"
Actual Results:  
Truncated download (size is consistent)

Expected Results:  
I would expect the full 4.3GB image

wget under FreeBSD solved the issue... I think MinGW's wget should work too (have not tried it on this particular file)

Updated

9 years ago
Component: Download & File Handling → Download Manager
Product: SeaMonkey → Toolkit
QA Contact: download → download.manager
Do you use ntfs or fat32 as filesystem ?
I had no problems with the file but aborted manually at 2.2GB with SM trunk.
(Reporter)

Comment 2

9 years ago
The filesystem is NTFS.
Do you use a proxy or something that installs a transparent proxy like a Antivirus product ?

IE7,SM2 and FF3.5 are able to handle files over 4GB except if you use fat32 but that is a filesystem limitation (maximum filesize is 4gb-1 byte).

Comment 4

9 years ago
Works for me using - Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6

Comment 5

8 years ago
Works for me too. Firefox 4.0b11, ubuntu x64 10.10 (with kde-desktop)
Marking works for me then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.